0

I was trying to restore my Oneplus two to stock it failed. using the toolbox allowed me flash and boot into stock recovery.

From here, I've tried sideloading the stock Rom which completes but won't actually boot. Flashing TWRP also returns an "okay" but I cant actually boot into TWRP recovery. There is no OS installed.

  • I can get into stock recovery

  • I can get into fastboot

  • I can get into qualcomm mode

  • Bootloader is unlocked

  • I can't boot into custom recovery

  • I can't boot into system after sideloading "success"

Can anyone help me? Thanks in advance.

0
  • Full factory image for OnePlus 2 → Download here| File name: OnePlus2Oxygen_14_OT…stboot.rar

  • Stok recovery : Download from here. File name: optstockrecovery.7z

Flashing Instructions

Step 1: Download the Factory image from above links.

Step 2: Make sure you have setup ADB and Fastboot on your PC.

Step 3: Boot your device into bootloader  (Fastboot mode).

Step 4: Navigate to the location where you have placed the factory image file on PC and extract it to get all the files like system, bootloader, etc along with the flashall.bat file as well.

Step 5: Run the flash-all.bat . Wait for the process to complete. If you use Linux or Mac OS, then run the flash-all.sh file and follow the instructions. But first, open the flash-all.sh file and verify if the files start with “./” prefix for Mac and “sudo” for Linux. If not, then add a prefix to every file.

Step 6: Once done, reboot the device into system either manually or using the command: fastboot reboot.

Flashing Stock Recovery

  • For ADB and Fastboot download the quick ADB and Fastboot Installer from here

  • Boot in Fastboot mode again

  • Unzip the file fastboot optstockrecovery.7z

  • Copy its content to the folder where Minimal ADB and Fastboot os installed (right-click on its icon > Open file location).

  • Flash the recovery with fastboot flash recovery optstockrecovery.img

  • esQmo I followed your instructions but it results in a boot loop, but this is still progress so I thank you. – brian fernandez Dec 11 '16 at 5:06
  • I forgot to mention when running flash_0x211.cmd i get an error but i close the error dialogue and the program continues – brian fernandez Dec 11 '16 at 5:39
  • what error? can you show a screenshot? – esQmo_ Dec 11 '16 at 6:27
  • For bootloop: Try booting in recovery and wipe data and cache – esQmo_ Dec 11 '16 at 6:29
  • this is the error I see "invalid sparse file format at header magi" but as I mentioned it will continue to run after closing the dialogue. I will try clearing cache and data, thanks – brian fernandez Dec 12 '16 at 0:38
0

I'm so stupid, I had not placed the files within the platform-tools folder, that did the trick. the system.img was too big to be flashed directly and needed to be compressed into several sparse files, performing the operation withing platform-tools will do this automatically.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.