5

if this the completely wrong place for tech support stuff I am sorry and would really appreciate it if someone would point out where to ask this question.

I already tried contacting Whatsapp's customer support, but they were less than helpful so far.

Since I already explained my problem to them, I'm going to post my e-mail exchange so far.

Dear Whatsapp support

Yesterday evening Whatsapp encountered a problem and asked me to reinstall the application. Trying to do so, I uninstalled the app via the PlayStore and, when trying to reinstall it, encountered error code -11. I originally thought this might be a problem with the PlayStore, but now I'm not so sure anymore.

Things I've tried so far:

  1. Manually remove all remaining files associated with Whatsapp from my phone.

  2. Cleared PlayStore data and cache.

  3. Uninstalled and reinstalled all PlayStore updates.

  4. Reset my phone to factory default.

  5. Tried manually installing an older version of Whatsapp.

Lastly I tried to manually install the latest version of Whatsapp. When I try this I get a parsing error. I downloaded the APK twice to make sure the download wasn't corrupt. This leads me to believe it might be problem with the APK and my specific device, and not the PlayStore.

The device in question is a Samsung I9070 Galaxy S Advance running android version 2.3.6.

If you require any more information I gladly provide them.

I apologize for any grammatical errors, English isn't my first language.

Best regards Marco

And their less than helpful reply, which is the reason I'm posting here, instead of trying to get help out of a robot, or a person acting like one.

Hi,

Thanks for contacting WhatsApp. Your request has been received.

Please understand that we prioritize reports of issues with the application and provide a comprehensive FAQ to solve most other questions.

Based on what you wrote in your message, we think that one of the following may be helpful for you:

To set WhatsApp to a different language

If you want to change your keyboard language or auto-correct settings

Additionally, if you wish to change your input language, we recommend using Google's input apps available in Google Play Store. For all other language related questions, please check our FAQ If our FAQ does not help, make sure to go to our website on your phone's browser to download the latest version and then reboot your phone.

-- WhatsApp Support Team

Take a look at our FAQ!

So, yeah, this is where I'm at. I really hope you guys are able to help, or at least point me in the right direction.

6

From my own experience the actual WhatsApp 2.16.382 version is not running anymore on devices with Android version lower than 4.0 (officially 2.1 and 2.2) since they launched the video call feature.

It seems like they have dropped the support for those devices as they did for Windows 7 - 7.5 phones, Symbian S40-S60 and Blackberry OS 7 and lower according to their blog.

You should try version 2.16.225 or 2.16.259 (find the apks) which worked for me.

  • 1
    Thank you esQmo. Version 2.16.259 gave me the original error that started the whole thing, but 2.16.225 actually worked and it's up and running now. I assume that sooner or later this old version might not be compatible with the new one anymore, but hopefully I have a new phone by then. – Marco Ortmann Dec 10 '16 at 17:21
  • Well this answer did not actually work for me, the app did get installed but it telling Whats app is has a problem & needs to be installted again, then it tells me to install via Playstore – penta Dec 11 '16 at 13:49
  • @penta : Try this: android.stackexchange.com/questions/164153/… – esQmo_ Dec 11 '16 at 13:53

Not the answer you're looking for? Browse other questions tagged or ask your own question.