0

I recently backed up all of my stuff to my Galaxy S5's SD card using Titanium Backup. I decided to test the backup using factory reset (I'm using the stock ROM) and trying to restore the backup afterwards. However, every time I try to do this, I get an error message saying "There is a problem parsing the package."

I've tried changing the backup location as explained here: https://seo-michael.co.uk/titanium-backup-problem-parsing-package-fix/

I've also tried updating SuperSU and changing the name space option as explained here: I can't restore apps with titanium back up

So far, nothing has worked. And I have to force stop TB to try and restore again (it stays stuck at 0% in the notification bar otherwise).

Have I done something wrong? Am I screwed?

  • That error message most likely originates from the package installer; you find a lot of hits searching Google for it. Most likely reason are corrupt .apk files. Have you tried installing one of them via ADB (adb install package.apk)? Do you get the same error there? Can you unzip the APK files, or does ZIP throw an error about "broken archive" when you try that? – Izzy Dec 10 '16 at 22:08
  • I just tried extracting a .apk.gz file in /storage/emulated/legacy/TitaniumBackup (which is where I moved my backups to). It says "Operation completed with errors" and the folder that should have the extracted files is empty, so I guess the .apk.gz archives are corrupt. The .tar.gz and .properties files seem fine, however. The same thing happens in /storage/emulated/0/TitaniumBackup. I must have messed something up trying to move from internal storage to the SD card when I first backed up my phone. – Pete L. Dec 11 '16 at 1:06
  • Sounds like. You could try obtaining those APKs again (e.g. using Raccoon on your computer, or downloading from apkmirror/apkpure), then replace the broken ones, and try a restore again. – Izzy Dec 11 '16 at 1:20
  • ^I guess I could try that, but I would like to know how to prevent the .apk.gz files from becoming corrupt when I backup stuff so I can just restore my apps+data using TB instead of re-downloading them all from Google Play and then restoring the data. – Pete L. Dec 12 '16 at 1:23
  • That's the next step then, and would most likely require involving Joël (the dev). For that, I'd watch logcat while backing up a single app, and see if there are any indicators – then either adjust to avoid the error, or send a bug report to TitaniumTrack. But now, first, to save your current backup – or aren't you interested in that part? – Izzy Dec 12 '16 at 7:28
0

There is one issue not mentioned online. When you disable Google Play Store - you need to untick some setting under security. You need to tick Unknown sources and UN-TICK Verify apps - while Play Store is still installed and actively running.

At least this solved parsing issue for me without the need to do backups again. Somehow google has managed to block Titanium backup ...

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.