1

My LG Nexus5X has randomly died this morning(it had ~70% battery). I have tried to leave it on charging for 1 hour straight and then tried to turn it back on. It worked. But then it randomly died again while being fully charged. It hasn't turned on ever since.

After shutting down for the second time I have also managed to enter the Fastboot menu (clicking Power Button+Volume Down button), although I get the menu to show and I can scroll through the options, when I click Recovery mode or Start, I get a screen with just saying 'Google' on it and then dies again. For Start my understanding is that it should turn on and as for the Recovery Mode this is not a normal behaviour as I should be seeing an Android Robot as described here. I also tried the Power Off option, left it there for an hour charging and then tried to turn it back on, this time it went past the 'Google' page to the colorful spinning/loading circles page but the animation stuck and it turned off again.

After the above failure, my goal was to enter the Recovery Mode through my PC(I use Windows10): I have attempted to set up the drivers for adb and fastboot like described in this guide. The only time I get my Android to show up in the Device Manager so I could setup the drivers is when the phone itself is in the fastboot mode and it shows up as Kedacom USB Device->Android Bootloader Interface. Since I could not see my Android under Other Devices like the guide says I tried to setup adb/fastboot one at a time for the Kedacom USB Device->Android Bootloader Interface entry. In the command line when I type adb devices my device is not showing up fastboot devices this shows up: 0167ca36eedbc1ef fastboot. Also, when I type adb reboot recovery I get error: no devices/emulators found .

I have ran out of options and everything I tried does not seem to work. What is the solution to bring my Nexus5X back to life?

  • So it's recognized in fastboot. What's stopping you from just flashing a factory image? Locked bootloader? – Andy Yan Dec 11 '16 at 1:08
  • Thanks for the reply. How do I flash a factory image? – and_apo Dec 11 '16 at 1:41
  • This. I'll have it posted as an answer if it works out for ya. – Andy Yan Dec 11 '16 at 2:00
  • I followed the steps and when I execute the flash-all script it says "writing 'bootloader'... FAILED (remote: device is locked. Cannot flash images)" . Is it maybe because I didnt enable "On-device Developer Options" when Nexus was alive? – and_apo Dec 11 '16 at 2:59
  • Well yes... And do you have a custom recovery now? If not then you're pretty much out of luck - time to call Google. – Andy Yan Dec 11 '16 at 3:04
2

You should try flashing the factory image for Nexus 5X in Fastboot.

  • Download Nexus 5X (bullhead) Factory image Android 7.1.1 here or Android 6.0.1 here. And unzip the file.

  • Setup all necessary drivers

  • For commands to succeed, you should unlock the bootloader: fastboot oem unlock or fastboot flashing unlock. The device will show a confirmation screen. (This erases all data on the device.)

  • Open a terminal and navigate to where you unzipped system image previously downloaded.

  • Execute the flash-all script. This script installs the necessary bootloader, baseband firmware, and system.

Hope this helps you out.

If the above don't work, you should try instructions detailed on this thread.

  • 1
    OP did state he has a locked bootloader, so factory images are no go. The last link is very interesting though, I didn't know LG actually kept TOT capability intact for emergency. – Andy Yan Dec 11 '16 at 8:24
  • I provide this solution for others too. I think the second solution should work for him. – esQmo_ Dec 11 '16 at 8:39
  • Thanks for the reply but when I follow the guide(for the last link you provided) and reach the step to connect the device for Windows to install the drivers it says "USB device not recognised" – and_apo Dec 11 '16 at 11:38
  • You need drivers. Install them – esQmo_ Dec 11 '16 at 11:56

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.