2

I have Samsung Galaxy S+ (i9001) and the other day had a prompt from WhatsApp to update the app.

The update download but the installation fails and the app cannot be opened.

I tried downloading the APK of the latest version and even many of older versions but the issue is still there.

I know WhatsApp said they are ceasing support for Android 2.1 and 2.2, but my phone has 2.3.6, so it shouldn't be affected.

How to fix?

2

Yes, officially they said they won't support android 2.1 and 2.2, but since the last update only devices with Android 4.0 and above are supported.

Try installing 2.16.259 over 2.16.225:

  1. Download APKs for WhatsApp version 2.16.225 and 2.16.259.
  2. Install 225 first, don't open it
  3. Reboot the phone
  4. Install 259

But soon or later these versions will be dropped as well.

  • Thanks, man, you're great. It worked. How can I disable auto update for WhatsApp now to prevent it for not working anymore? – NoobNe0 Dec 11 '16 at 13:02
  • Disable it in Google Play > Settings > Auto update apps set it to do not auto update apps. Mind upgrading to a recent phone. Soon or later these versions won't work anymore. – esQmo_ Dec 11 '16 at 13:06
  • Yes. The phone is garbage btw, I'm upgrading it soon – NoobNe0 Dec 11 '16 at 13:08
  • Just for information: this webpage in the WhatsApp FAQ, which contradictorily claims compatibility for "Android 2.1 or later", is outdated and is no longer referenced from the main FAQ page. – anol Dec 13 '16 at 9:14
  • Where can (safe) older packages be found? This page is official but doesn't list older versions, and all others are not from official sources... – jjmontes Dec 13 '16 at 18:43
-1

You can install the Whatsapp version 2.16.155, it is the only one that worked well on my Galaxy GT-I5500.

You also need to set the clock to a previous date, to skip the "obsolete version" warning.

  • So, for now, it is not an answer. – Vivek Ji Jan 17 '17 at 17:30
  • ok, text updated :) – João José Feb 15 '17 at 11:08
  • Date and time for obsolescence​ is checked server-side, not client side – esQmo_ May 9 '17 at 20:05

Not the answer you're looking for? Browse other questions tagged or ask your own question.