I am coming before you because I am being stuck in recovery mode after I updated CyanogenMod 14.1 Nightly on my LG G4 h-815.

Indeed, I just performed a weekly update as usual but afterwards the system did not reboot as usual. In order to solve this issue, I performed the following operations:

  1. I reinstalled the latest version of Team Win Recovery Project, by following the instructions on this page: https://wiki.cyanogenmod.org/w/Install_CM_for_h815#Installing_a_custom_recovery_using_fastboot

  2. I booted in recovery mode and, in the menu, I selected "Wipe" and then "Format Data"

  3. I installed CyanogenMod and Gapps, by following the instructions on this page: https://wiki.cyanogenmod.org/w/Install_CM_for_h815#Installing_CyanogenMod_from_recovery

Unfortunately, when I reboot the system I am always back into recovery mode. I tried to install several version of CyanogenMod with the same result.

Does anyone have any idea of what I should do?

Thanks in advance!!



2 Answers 2


Thanks a lot esQmo for your answer!

I finally managed to return to stock. To do so:

  1. I downloaded LGUP here: http://oceanhost.eu/eps4h4pmwphu/LGUP.zip.htm and I installed LGUP_8994_DLL_Ver_0_0_3_23 first and then LGUP_Install_Ver_1_14_3 (I am running Windows 10)

  2. I downloaded the Frenche version of Marshmallow 6.0 for my LG G4 h815 here: http://storagecow.eu/index.php?dir=Xda%2FLG+G4%2FH815%2FMarshmallow+6.0%2F

  3. Downloaded the LG drivers

  4. I restart my phone into Download Mode and I plugged it to my computer:

4.1. Power Down the LG G4

4.2. Press and Hold the Volume Up Button on the LG G4

4.3. While Holding Volume Up, Plug the USB Cable into the LG G4

4.4. Continue Holding the Volume Up Button After You See ‘Download Mode’

4.5. Let Go of the Volume Up Button When You See the ‘Firmware Update’ Screen on the LG G4

  1. I runned LGUP and I refurbished my phone with the .kdz firmware file downloaded in 2.

N.B.: if your computer does not detect your mobile device, you should change the port to have COM41

Good luck!

  • ...should change the port to have COM41 Do you mean manually? Ypu should edit and add step to do so.
    – esQmo_
    Commented Dec 13, 2016 at 21:31

Apparently TWRP does not support the new update mechanism that Android 7 implements. So some data needs to be reset. OTA updates should work better with CM Recovery.

Got the same problem when trying to update from the 2016-12-01 nightly to 2016-12-11 on an LG Nexus 4 (mako).

These two commands in the terminal of TWRP fixed the problem:

dd if=/dev/zero of=/dev/block/platform/msm_sdcc.1/by-name/fota
dd if=/dev/zero of=/dev/block/platform/msm_sdcc.1/by-name/misc

Please note that using dd and /dev/zero is quite risky. You can easily corrupt your system even more. For me, it did the trick flawlessly but I do not understand what it does exactly. The phone booted the new nightly afterwards and works fine since.

Source and more information: http://androidforums.com/threads/twrp-bootloop-fix-after-update-ota.922585/

  • Welcome to Android Enthusiasts – and thanks for your answer! Could you please edit your post and include what that does, why it solves the issue, and whether there are side-effects? While in the linked thread several posts confirm this, dding /dev/zero to a partition completely blanks it. Aren't there any data supposed to be in place? Is any after-work needed?
    – Izzy
    Commented Dec 13, 2016 at 13:07

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .