Xperia Z3 D6633

I followed the very many tutorials (pick any on google) saying to flash (in fastboot) the file bootZ3monxtest01.img

fastboot flash boot bootZ3monxtest01.img

Now I have a bootloop around the sony logo.

No system, only recovery (TWRP) available

I can also reflash the whole system through Sony's Flashtool, but it kills the point, as a custom working recovery is required for later rooting

Obs. 1: Needless to say that the "usual" is to flash recovery onto recovery partition. I tried that. Nothing happened

Obs. 2: KingRoot rooting method worked, but I fail miserably to replace it by SuperSU

Obs. 3: It's my third attempt


  • The Flashtool also provides a rooting option, you can give a try. Just connect the phone with ADB and hit the padlock icon. – esQmo_ Dec 12 '16 at 11:53
  • Yes, yes ! That's an important detail that I forgot to mention on the main post: tried this built in tool both in flash mode and fastboot. Both returned an error that unfortunately I cannot remember. Can't remember either why I didn't try to research about that error... Could've resolved the issue much earlier... – Lucas BS Dec 13 '16 at 13:16

I found another method (buried lightyears deep on the net):


It flashes the recovery via ADB (requires a prior kernel change, though, that can be restored after)

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.