2

So I've done

# mv /storage/emulated/legacy/build.prop /system/build.prop

on my SM-T311 (Android 4.4.2) and now it won't boot. The only change I've made was adding one line at the end:

net.hostname=Tableta

I've tried using adb shell (forum.xda-developers.com/showthread.php?t=1927198) to revert the changes, but my PC won't detect the device when connected with USB cable in recovery mode. Although, when I select apply update from ADB windows detects it and it shows up in adb, but I can't do adb shell. (RESOLVED)

Is there a way to fix my tablet without losing my data, or am I doomed?

Okay, I've made progress. I've plugged the device in when it was boot-looping and windows detected it. Through device manager I've installed USB Driver for Windows, revision 7 and that made me able to use the ADB interface. I've confirmed, that build.prop file permissions and owner group are wrong. Unfortunately it wouldn't let me chmod the file or remount.

enter image description here

I've also tried

>adb root

but it hangs forever with no output so I have to close the console window.

0

If you have a custom recovery you could boot into you could dirty flash the stock rom of your tablet.

  • Unfortunately it's a stock recovery. – MacGyver Dec 14 '16 at 5:07
  • 1
    @MacGyver Then just flash one! – Andy Yan Dec 14 '16 at 6:43
  • Thank You @AndyYan for finding that tutorial for me! I've flashed TWRP and fixed permissions with its File Manager! It's alive! – MacGyver Dec 14 '16 at 17:03

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.