2

Running the latest Nougat beta on Sprint Galaxy S7.

Whenever I open a weblink within an app (such as reddit, Google Search/Now, Gmail) the link opens within the app, but as soon as it's done loading my phone switches to Chrome -- but does not open the link in Chrome.

To see the page, I have to switch back to the original app.

Is there a fix for this? I tried clearing Chrome defaults, disabling/re-enabling Chrome, uninstalling Chrome updates. No dice.

1 Answer 1

2

Try updating your "Android System WebView" application.

It may be happening because of the confusion to an app of choosing which web view app or you can say service to use...

I have CyanogenMod 14.1 which is based on Nougat. There's this option in Settings -> Developer Options -> WebView implementation

WebView implementation dialog

4
  • Aha ... mine is called "Android System WebView", at version 54.0.2840.85. In my Dev Options I only have the "Chrome Stable" option. But I am not rooted so I don't see how I can update this.
    – d0g
    Dec 15, 2016 at 15:24
  • OK, I updated via Play Store to version 55.0.2883.91 but it's marked as "disabled" and I can't enable. Weird.
    – d0g
    Dec 15, 2016 at 15:33
  • Installing Chrome Beta & disabling regular version seems to have fixed it for now. Apparently WebView is deprecated in Nougat.
    – d0g
    Dec 15, 2016 at 16:26
  • Related article regarding "Chrome as WebView", although it's focused more for developer.
    – Andrew T.
    Dec 16, 2016 at 20:42

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .