0

I have a OnePlus one mobile. The contacts that I store are getting stored in the Local Phone (I am able to see this when I select "Show Contacts from phone alone"). Those new contacts are not visible in my google contacts and these new contacts are also not visible in Whatsapp.

What should I do to resolve this?

  • 2
    If you want to store your contacts with Google, check your contacts app for what is set as default; make sure that's Google. Then add the contacts again (to my knowledge, you cannot "move them over"). While doing so, double-check it says to store the contacts to the Google contacts list (see the red frame in this picture for where to look for that). – Izzy Dec 15 '16 at 16:47
0

My solution was to migrate contacts from local storage to the Google account via an export and an import.

  • contacts app > manage contacts > Export

  • contacts app > manage contacts > Import => destination: Google => source: exported file

Also make sure to make Google your default contacts storage

  • contacts app > settings > Default Storage Location => Google

And turn on sync of contacts.

Unfortunately Export and Import won't bring across the local storage groups. Groups entered in Google do sync across back to the phone.

| improve this answer | |
0

Try saving all contacts you want to sync to Google. This should fix the problem. You do this by opening the contact page, tapping edit, and then tapping on the "Location" text box. This will open another window and you should be able to change where the contact is stored. You also need to go to Google Account settings (in the Accounts section of Settings), and ticking Contacts under What to sync.

| improve this answer | |
0

Best way: Sure way with back up

Idea: Save your contacts to a file (.vcf) from your phone. Then transfer that file to your computer. Log on from your computer to Google account, go to contact page, then chose IMPORT option using that .vcf file.

If you can plug in a chip (USB) to your phone to copy the .vcf file, that works flawlessly when you plug the same chip to your computer.

| improve this answer | |
-2

Try re syncing your contacts. I had this same problem and re syncing my contacts work.

| improve this answer | |
  • 1
    That won't accomplish anything if the contacts are stored "locally" instead of being stored as Google contacts. – Izzy Dec 15 '16 at 16:42

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.