I bought a cheap Wiko Lenny 3 (MT6580 with Marshmallow) to replace my old Galaxy Nexus which died yesterday (after four years) from the infamous V3U00M bug.

I owned a couple of Android phones before the Nexus, and I often flashed new ROMs and recoveries, so I'm quite used to adb and fastboot (under Linux).

So, I'm trying to root this new phone but so far I've been unsuccessful. Unlocking the bootloader was quite easy: there was an item to check in the developer options, and then fastboot oem unlock did its thing. But after that, I'm stuck.

I'm trying to boot a custom recovery, the file seems actually transferred:

$ fastboot boot twrp3.0.2-lenny3.img downloading 'twrp3.0.2-lenny3.img'... OKAY [ 0.446s] booting... OKAY [ 0.065s] finished. total time: 0.511s

The feedback on the phone seems to indicate that the transfer actually happened, but after that, it just sits there, instead of rebooting into TWRP. After a while, it reboots normally to Android.

Trying to flash the recovery instead of booting it ends up with the same result: the transfer works, all on-screen messages (both on the computer and on the phone) indicate success, but the stock recovery isn't overwritten.

I thought that there may be some kind of manufacturer script that checks the image's validity, but trying with the stock recovery image (extracted from a Windows executable provided on the manufacturer's website to recover corrupted phones), but the result is the same: the file is transferred, but nothing happens after that.

So I tried to install the SuperSU zip from the stock recovery, since it includes options to install updates from either an SD card or ADB sideloading (but I have a doubt about this, I used custom recoveries for so long now, that I forgot if a stock recovery including these options should be able to install any zip file, or only ones containing a full factory image). Unfortunately, it didn't work either: installing from the SD card failed with the message "Installation aborted", and the sideloading option, surprisingly, doesn't seem to even start an ADB daemon : adb devices returns an empty result, so obviously adb sideload can't work (needless to say, adb works normally when the real system is booted, and I can adb push and adb pull to my heart's content).

Can someone help me ? Are those non-functional bootloader and recovery a pattern with Wiko and/or MediaTek devices ? Either I'm too much used to Nexus devices and I'm doing something wrong, or this phone seems to be intentionally crippled by the manufacturer.

Interesting: by trying several key combinations to start the phone, I found a "Factory Mode" that I never saw on any Android phone so far, with a menu allowing to run tests; and, also, a "Meta Mode" which look like "Fastboot Mode" but doesn't answer to fastboot commands - I guess it's meant to be used with a special proprietary tool from this manufacturer. That's what makes me wonder if these MediaTek-based phones are supposed to be hacked with the usual adb and fastboot tools, or if they are completely different beasts.


1 Answer 1


You can't root with ADB or Fastboot because you don't have the ''adress" where the files will be sent. Mediatek devices need a map file, called scatter files which maps the memory and tells the flashing tool where every file should go, the start adress and the file size.

As they run Android, Mediatek devices can be manipulated with adb and fastboot (depending on manufacturer: Alcatel and Huawei seem to support fastboot commands).

META mode is like fastboot, as you've pointed out. Besides you can enable ADB in META mode, it is used by hacking tools to access internal memory, as an example for network unlocking, IMEI repairing and so, you need special drivers CDC and VCOM to get it work though.


You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .