I want to unlock my Nexus 5. I cannot run any fastboot command however: the device is not detected. What I did:

  1. Press VolumeDown+rightButton until arriving to this screen

enter image description here

  1. Plug the phone

  2. Run the following commands

though I appear to be in fastboot mode

# apt-get install fastboot
# fastboot oem unlock
< waiting for device >

Nothing is disaplaye after the last line.

PS: I am using Ubuntu 16.04

  • If that's your device in the screenshot (rather than an image taken from elsewhere) then it looks like it's already unlocked. That could explain why it doesn't show anything.
    – bmdixon
    Dec 17, 2016 at 17:42
  • @bmdixon It should, no matter it is unlocked or locked. otherwise how do you do if you want to relock it?
    – esQmo_
    Dec 17, 2016 at 21:05
  • 1
    This is 6 months late, but adding sudo to the fastboot cammands solved the problem for me
    – Naved
    Aug 2, 2017 at 8:42

1 Answer 1


You probably don't have USB drivers installed. Download them and install, everything should work now.

  1. Download them from here
  2. Download Galaxy Nexus drivers here

    • Power on the device

    • Go to Settings > Developers Options > USB Debugging then enable it.

    • Connect the device to the computer, drivers should be installed

    • Open a terminal and check if the phone is detected: adb devices (Windows)

    • You should get some hex numbers as output

    • Then reboot to the bootloader: adb reboot-bootloader

    • Then check if the device is detected in Fastboot: fastboot devices

    • Finally proceed with the Unlocking process: fastboot oem unlock or fastboot flash unlock if the previous doesn't work.

PS: Seems like you use a Linux system, I'm not familiar with Linux. You should use Linux commands.

  • You write "You probably don't have USB drivers installed" <-- I have an OPPO A9(maybe same as OPPO A5) phone, I think it can't get to a boot loader.. I understand that maybe fastboot commands require that one is in the bootloader. I can do adb devices, so I think my USB related adb drivers are fine.
    – barlop
    Jan 14, 2021 at 5:25
  • Did you try booting into the bootloader with ADB?
    – esQmo_
    Jan 14, 2021 at 10:00
  • It's an OOPPO A9 2020.. When I do adb reboot bootloader it just restarts the phone into the system, it doesn't go to the bootloader. If I do power-voldown, and start it then it still doesn't go to the bootloader, it goes to a recovery called ColorOS
    – barlop
    Jan 14, 2021 at 19:51
  • Well, if I'm not wrong, you need to Volume up + Power to enter bootloader mode. Did you try it already?
    – esQmo_
    Jan 14, 2021 at 20:45
  • Oh and there should be a parameter that you need to enable, located in the Developpers Options settings: Check if OEM Unlocking is present and enabled.
    – esQmo_
    Jan 14, 2021 at 20:47

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .