From one day to another it seems that A2DP stopped working for me. I used it to stream music from my phone to my car's stereo. Everything worked fine until yesterday. I didn't install or upgrade any software as far as I remember. What happens now is that everything seem to work but I don't hear anything. The media player on the phone is running. When I adjust the volume on the phone I see the popping out slider showing 'bluetooth media volume'. Also I can skip tracks using my car's buttons (AVRCP profile) and display track information in my car's display (ACRCP 1.3 supported by Samsung media player on Galaxy SII). I can use the phone, too (handsfree profile), here I can hear everything.

I think its a matter with the phone and not with the car since I tried another phone, that works as expected. Unfortunately I don't have another A2DP headset or similar to try with my phone.

A already tried to delete the pairing and pair new but it didn't help. Ideas anybody? I use a Galaxy SII running 2.3.4.

One more thing I should mention: I don't think that this is the reason but I had an issue with my phone's micro USB port the same day. It was always saying it's getting charged via USB but it wasn't. Also car mode switched on and off sometimes without user interaction. So I removed the battery, tried to clean the micro USB port by blowing in it, waited some hours and after that everything's fine again. But as I said, I don't think that this is related since there's no reason why a defect micro USB port (and it doesn't seem to be defect though) should stop A2DP working.

Update: Found this similar problem and will try unpair, remove battery and pair again as suggested tomorrow. Will give an update here.

2 Answers 2


Finally I found the solution: When in car mode (automatically toggled using Llama when my car connects via Bluetooth), I use Car Dock Home v3 as home replacement. Inside it's preferences in the "Car Mode System Settings" there's an option called "Samsung USB Mount Au..." (can't read the complete entry). I had already forgotten that I checked this option since I wanted to know what it does. Now I know that it mutes A2DP ;) No Idea what it should do but fortunately now I have sound again.


Had a similar issue between Nexus S and 2012 Kia Sportage. Worked fine for about a week, then audio streaming just stopped. Connection was still good, could make and receive calls. Tried a number of things like cycling the BT on/off, disconnecting/reconnecting, renaming the phone, etc. Brought it to dealer but was told the problem was with the phone since they were able to stream using an iPhone. In the end, a soft reset (power off/on) fixed it.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .