I just got a new MacBook 2016 with Mac OS Sierra installed, after setting up my complete development environment and all required tools via Android Studio, I tried to flash a new Android Wear release on my watch.

ADB is working without issues, but as soon as I try to run any fastboot command (other than fastboot help) it will completely freeze and never finish.

It is just stuck with no output at all.

I already tried to run it with sudo or reinstall it via the SDK Manager, I also tried different standalone fastboot binaries provided on XDA developers.

There is nothing which seems to make it finish. Even "ctrl + c" won't exit the running command. Only killing it via the process list will work.

  • Did you setup all drivers? When fastboot "freezes" it's because the device is not detected. I never tried on Mac but on Windows it shows Waiting for device
    – esQmo_
    Commented Dec 18, 2016 at 17:45
  • It won't even show this output. So everything is installed. Tools all dependencies. (adb working without issues)
    – mikepenz
    Commented Dec 18, 2016 at 17:47
  • How do you get in Fastboot mode?
    – esQmo_
    Commented Dec 18, 2016 at 17:49
  • @esQmo I have installed the tools on my pc and added the tools folder to the path variable. so I just type "fastboot devices" and it won't output anything. The device was set to fastboot by doing "adb reboot bootloader" (also tried with other devices) the thing is that fastboot won't output anything at all, no warning that it's waiting for a device, nor anything else
    – mikepenz
    Commented Dec 18, 2016 at 17:55
  • Did you follow the step by step instructions like these from here ? stechguide.com/…
    – esQmo_
    Commented Dec 18, 2016 at 18:00

4 Answers 4


So this was an official Android fastboot bug. They are currently testing a fix in their QA department.

With the new platform tools release it will be fixed: https://code.google.com/p/android/issues/detail?id=231129


Not really a solution but a workaround: I've been having the same issue without finding anything online. Am using a 2016 Macbook Pro, Nexus 4 and a USB A to micro USB cable with an A-to-C adaptor.

I used Parallels to run a virtual Ubuntu machine and installed fastboot there (as per here to minimize storage usage). When I plug my phone in I tell Parallels to connect it to the virtual machine. Not ideal, but at least I can use fastboot!

  • oh interesting. So it seems the new MacBook or USB Type C (Thunderbolt 3) is somehow incompatible with fastboot. I wonder why there is no bug report for the android tools, nor anywhere else open yet.
    – mikepenz
    Commented Dec 19, 2016 at 10:14
  • Running into the same issue on a new Macbook Pro 2016 and the latest version of fastboot with a Nexus 6p. I have tried the Apple usb-c to usb-a adapter and even a straight usb-c to usb-c cable. It just hangs.
    – duckworth
    Commented Dec 19, 2016 at 16:02
  • 1
    Yeah, I think it's definitely a MacBook USB/Thunderbolt issue. Surprised I haven't seen more information about it. We can't be the only two with the new MacBook trying to use fastboot!
    – jimmygoska
    Commented Dec 19, 2016 at 19:12
  • Just asked a colleague of mine to test this too. He was also able to reproduce it
    – mikepenz
    Commented Dec 19, 2016 at 21:56
  • Can also confirm this issue on a 13 inch MacBook Pro 2016 model, fastboot from homebrew and a OnePlus 3 device.
    – nover
    Commented Jan 2, 2017 at 20:35

Google has released an update to Android Platform Tools that fixes this. You can use Homebrew to install the latest version:

brew update
brew install android-platform-tools

Once you update to revision 25.0.4 or above, fastboot will no longer hang on Macbook Pro 2016 / MacOS Sierra. From its changelog:

25.0.4 (March 16, 2017)

  • Added experimental libusb support to Linux and Mac adb

To use the libusb backend, set the environment variable ADB_LIBUSB=true before launching a new adb server. The new adb host-features command will tell you whether or not you're using libusb.

To restart adb with libusb and check that it worked, use

adb kill-server; ADB_LIBUSB=1 adb start-server; adb host-features`

The output should include "libusb".

In this release, the old non-libusb implementation remains the default.

  • fastboot doesn't hang 2016 MacBook Pros anymore (bug 231129)
  • Fixed Systrace command line capture on Mac

Similar symptoms, different versions. On a Macbook Air M1, with a phone connected over USB-C, adb worked fine for me but fastboot (34.0.0 from Homebrew) just hung there (though in my case Ctrl+C worked).

The solution for me was to plug the device in a different port. Only the port closest to the back worked for fastboot.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .