I have a tablet and I'd like to use adb but I have some probles, I looked on google but without luck...

Tablet Info: (from tablet)

Model Nr: SN10T1
Android OS Version: 2.2
TapUI Version: 1.2-4204
Kernel Version:
Build Nr: FRF91

I did the following:

  • Activate Debug Usb on tablet

  • Downloaded and installed android-sdk and google-usb-driver

  • Edited the file extras/google/usb_driver/android_winusb.inf adding under [Google.NTx86] and [Google.NTamd64]

    ;NVIDIA Tegra

    %SingleAdbInterface% = USB_Install, USB\VID_0955&PID_7000

    %CompositeAdbInterface% = USB_Install, USB\VID_0955&PID_7100&MI_01

Restarted adb but using adb devices it does not show the tablet....

I checked under device manager the VID and PID of my device and VID = 0955, PID = 7100 so they are the same of the file above...

Triyng to reinstall the driver using extras/google/usb_driver/android_winusb.inf I got this error:

The folder you specified doesn't contain a compatible software driver for your device. If the folder contains a driver, make sure it's designed to works with Windows x64 based system

I have windows 7 64bit Professional...

  • 1
    Have you looked for drivers from the manufacturer? Dec 4, 2011 at 16:54
  • I can't find the driver... if they exist
    – Marcx
    Dec 4, 2011 at 20:38

1 Answer 1


Follow the instructions here. I just followed them (changing the PID and VID numbers as you did and it worked!)


  1. In the changed .inf file remember leaving an empty line after pasting the code after [Google.NTx86] or [Google.NTamd64]; and also after it and the beginning of the next paragraph.
  2. Don't forget the step 5 where you must put your VID number (example: if your VID is 0955, then put 0x955).

And the rest is exactly the same. It worked for an Excite 10 from Toshiba with Tegra 3 processor.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .