9

About a month ago, Messenger implemented an in-app browser, similar to the one on the main Facebook app. It's terribly slow, and I'd love to load links in Chrome (or Tumblr, or Twitter, or whatever app is actually meant for the link). I've looked all over and cannot figure out how to disable it - all help I find is for Facebook's in-app browser, not Messenger's. I'm using a Oneplus 3 with the default Oxygen OS. Thanks!

migrated from webapps.stackexchange.com Dec 25 '16 at 2:30

This question came from our site for power users of web applications.

3

Not sure if you figured this out or not, or maybe they fixed it, but I figured it out. Open messenger. In the far upper right corner, tap the silhouette icon that takes you to your profile. Scroll down and check "open links externally"

  • I've got this set, but it doesn't seem to work on all links. I'm tempted to re-install and see if that helps because there is no obvious reason for it not to apply. – Mark Aug 15 '17 at 22:29
10

Go to messenger, go to Photos & Media and switch on: "Open Links in Default Browser"

A

(Click to enlarge)

  • They have really hidden this setting, but thanks to this guide I found it, and set it. Now it appears to not have any affect on a link I'm really keen to open in chrome. – Mark Apr 5 '18 at 21:01
  • Should be the accepted answer – Sheharyar Jun 14 '18 at 7:16
5

While this is a feature of the Facebook app itself, it appears there is no feature to do this with the current version of Facebook Messenger as of this answer (version 100.0.0.29.61).

The only current method in order to use the Android assigned default application for the URL is to Click the Menu Icon and click Open in ...

However if you are noticing that your in-app browser is slow, you may need to head into your Settings -> Apps and clear cache for Android System WebView and Google Chrome. (You may have to turn on Show System in the three dot menu.)

  • This option appears to have been removed, at least on my device. The "share" option only let's me share on messenger. Opening the messenger website in chrome doesn't let me use messenger. Looks like the only way to get a URL out of Facebook messenger is on a desktop browser! – Mark Apr 5 '18 at 21:02

Not the answer you're looking for? Browse other questions tagged or ask your own question.