1

I can't change the file and folder permissions on my rooted android 4.4.2 device. I tried doing this from Root Explorer, Total Commander and also from terminal emulator and it didn't worked. Any idea why?

  • Permissions of what? Which files or folders? Some filesystems like FAT32 don't support UNIX permissions and therefore you can't change them. – GiantTree Dec 27 '16 at 10:15
  • Yes, i think the problem is because the file system is fat32, though the commands i run from the terminal df and blkid didn't get me much info about that. – user1800997 Dec 27 '16 at 10:37
  • Probably refer to this one I answered not long ago. – Andy Yan Dec 27 '16 at 10:38
  • @user1800997 Which folders are we talking about? – Death Mask Salesman Dec 27 '16 at 16:28
  • If you have solved your problem, post the solution as an answer rather than editing your own question. – SarpSTA Dec 27 '16 at 18:27
2

I guess the file system you are working on is mounted as readonly mode. /system is readonly by default. You need to run the following command to re-mount it as read-write

su
mount -o rw,remount,rw /system

Another guess is that the file has immutable attribute. Try run this command as root to remove immutable attribute from the file.

chattr -i YOUR_FILE
  • 1
    Good answer, which you might want to integrate with some info about the /storage/emulated/0 mountpoint, since OP didn't specify the culprit folder. In fact, since the abovementioned is masked via FUSE, changing ownership and permissions on it isn't allowed, and even the root user has to work on the original folder, which resides in /data/media/0 in order to edit permissions. – Death Mask Salesman Dec 27 '16 at 16:27
0

The problem was caused by the fat32 file system of the sdcard.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.