0

I just bought a new smartphone and the new Android (6.0.1) has this peeking thing that really annoys me. I wanted to disable it, for example for WhatsApp, so I went to

Settings -> Sound & notification -> App notifications -> Whatsapp -> Allow peeking (off)

This solves the issue. The problem is that when I turn the device off and then turn it on again, these settings go back to default and the peeking is re-enabled without my doing anything.

Is there a way to permanently disable peeking?

EDIT:

I've found this link and option 1 seemed very promising. However, I did that and it didn't work either. Still looking for the solution, though.

  • Wondering if your WhatsApp is on sd card ( not phone storage)- if so, reverting to phone storage and checking may help? – beeshyams Jan 4 '17 at 13:29
  • @beeshyams I've been looking this up on the Internet and that seems to be the problem for almost everyone. However, in my case, I have no apps on the SD Card, so this wouldn't be my case. It's really driving my crazy. – Tendero Jan 4 '17 at 13:31
  • Is it only WhatsApp or with all apps? – beeshyams Jan 4 '17 at 13:32
  • @beeshyams I don't know if all of them, but it appears to be a general problem, because I had turned peeking off for 6 or 7 apps and all of them reset after reboot. – Tendero Jan 4 '17 at 13:35
  • 1
    @beeshyams I just checked again, and it is only WhatsApp that is having this issue. I was wrong before, I got confused with all the tests I did and they were all on normal because I had put them like that the last time. – Tendero Jan 5 '17 at 0:30
1

Well, I finally got it to work. I'm going to post the solution just in case someone is having the same problem. I did exactly as it is stated here: just toggling another one of the other two options in the notification settings did the magic.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.