0

I have a 12 hour audio file that contains ambience that I listen to while sleeping in noisy places. My old phone running Android 2.something can play it without problems using MX Player. My newer phone, a Galaxy S4, running 4.something, can play it with MX Player but it will occasionally glitch, causing the sound to drop out for a moment before resuming. This wakes me up and is thus unacceptable. At this point this is about the only use I have for the old phone and I'd like to stop using it, but I need this functionality. The other apps I tried seem to hang on the file's long duration or size (500MB).

I'm not sure if the glitching is due to MX Player or if other phone processes are interrupting the sound access or processor usage. Is there a better way to play large audio files? Or is there an app that can seamlessly loop a shorter audio file?

  • Is your phone connected to power while listening? It may be possible that the phone (or phone's processor) tries to enter deep sleep (effectively shutting down the processor to conserve battery) after a long amount of time. Audio players often use what is known as wake locks to keep the phone running but those are not meant to run for long amount of times. – GiantTree Jan 4 '17 at 19:50
  • Why not try to play it with an Audio Player app? Like Apollo or Timber? If the simptoms are the same it means not the player coused the problem but the hardware or Android version (deep sleep, battery saver profile) or the ROM (official Samsung ROM with full of bloat). – Bálint Babics Jan 4 '17 at 22:52
  • You should actually try using the sound player that comes with the system (I'm not sure how it's called on Samsungs, on Nexus phones it's Google Play). Also make sure that any effects in the player (equalizer, bass boost, etc.) are turned off. This way, the sound file will be most probably played using "offload" path (decoded on DSP) which is the most power-saving and least glitchy. – Mikhail Naganov Jan 5 '17 at 1:19
  • So there doesn't appear to be any sound player that was included with the system. Or perhaps there was one and I disabled it at some point. Apollo seems to no longer exist under that name, and Timber was rated considerably lower than a similar app called Musicolet, so I tried that. Same problem. – intuited May 29 at 2:24

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.