0

I have adb and fastboot installed, but when I got into fastmode on my Zenfone 2 Laser it won't list the device anymore.

I am using Ubuntu and the adb/fastboot seem to work just fine in the terminal. However when the phone is in fastboot mode it is lost from the list. Debugging is on too.

Basically I am trying to do this: https://forum.xda-developers.com/zenfone-2-laser/general/guide-marshmallow-root-guide-ze500kl-t3380461

I am trying to boot TWRP without flashing the phone, so that the bootloader and SuperSu could be installed.

  • Fastboot only works when the device is booted to the bootloader screen. If you type in fastboot devices, what happens? For Linux, have you added the file for udev rules to /etc/udev/rules.d/ ? – DukeSilversJazz Jan 6 '17 at 14:17
  • Thanks for the reply. That's interesting, because the tutorial says it has to be in fastmode. I am on in recovery at the moment and can see the device either in recovery or sideload mode (in the terminal....depending what I choose). I am fairly confused. I thought I could just install TWRP and then the bootunlock and supersu, but it doesnt seem to be that easy. Basically I'd like to unlock the bootloader and root the device using ADB sideload. So, that I could install TWRP from Google Play and then using TWRP install a custom ROM. – Elysium Jan 6 '17 at 14:21
  • @RMarkwald it says no permission, so I tried using "sudo fastboot devices", then it gives the ID and the status "fastboot". So, it seems to work. I have typed "sudo fastboot boot recovery.img", but it says "cannot load", but it is there for sure. I copied it to the main folder of the phone memory. – Elysium Jan 6 '17 at 14:57
  • What if you put the TWRP.img file in the same folder of your computer that fastboot is in, then running that command? – DukeSilversJazz Jan 6 '17 at 16:43
  • I have just managed to install TWRP. It wasnt difficult, but I simply can't root the device. Nothing works. None of the things on the internet. I have tried this: asus-zenfone.com/2016/05/… I have no clue what is wrong with this device. So, TWRP is installed, device is unblocked, but I can't root it. – Elysium Jan 6 '17 at 16:48

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.