0

I have managed to install TWRP, unblocked the bootloader, but I simply can't root my device.

I have tried this: http://www.asus-zenfone.com/2016/05/how-to-root-asus-zenfone-2-laser-ze50kl-marshmallow.html

I have also tried this one: http://technoplanners.blogspot.in/2016/02/root-asus-zenfone-2-laser.html

It doesn't work either.

Do I even need root access for a custom ROM installation?

I am trying to install Ressurecition Remix. I was wondering if that grants root access during the installation?

5
  • I don't know why can't you? What problem do you encounter? Is it simply not working where it should or does it give an error?
    – SarpSTA
    Jan 6, 2017 at 17:12
  • It looks all fine (I mean it gives no error message), but then when I check it with the app..it says the device is not rooted. I have just tried again from this website:technoplanners.blogspot.com/2016/02/… and it gives this error message in adb: "downloading 'boot.img'... OKAY [ 0.669s] booting... FAILED (remote: dtb not found) finished. total time: 0.690s "
    – Elysium
    Jan 6, 2017 at 17:14
  • Add that to your question. Your question, as is, very non-detailed and is very hard to answer. Detail it to your best effort to boost your chance of someone posting a good answer that'll solve your problem.
    – SarpSTA
    Jan 6, 2017 at 17:17
  • Ok. I'll do my best, but I just simply want to root my asus device and none of the 2 tutorials cited can do so. It's weird. There seems to be no definite solution to rooting asus zenfone 2 laser ZE500KL devices. A bit weird. I dont get any error messages, nothing....but then when I check it, it is not rooted.
    – Elysium
    Jan 6, 2017 at 17:19
  • What is the output of adb shell su ? does it change from $ to # ?
    – esQmo_
    Jan 6, 2017 at 21:26

0

You must log in to answer this question.

Browse other questions tagged .