It's not just in the play store, it doesn't work on mobile or on PC, and I also can't do any in-app purchases in any app. I tried reinstalling apps, clearing phone, but I believe it has nothing to do with the phone because it's not working on PC as well... If I go to google payment center, I get "You haven’t signed up to pay for any Google services yet", and I successfully bought an app a few months ago.

  • It looks like the error is on Googles side. Have you tried to contact google play support? support.google.com/googleplay/answer/6179357?
    – kirodge
    Jan 9, 2017 at 19:40
  • By any chance have you changed or renewed your card ?
    – beeshyams
    Apr 5, 2017 at 10:29
  • If you did and that card is not EVM enabled, that could be a reason
    – beeshyams
    Apr 5, 2017 at 10:55

2 Answers 2


This usually happens for one of two reasons:

  • The payment information registered to your Google account is invalid and causing problems.
  • The application data of the Google Play Store is corrupted

Managing your payment information

Verify if your payment methods are still up-to-date in Google payments center and in the account section of the Google Play Store. Note that they should match the personal information of your Google account.

Clearing the Google Play Store cache

  • Open the Settings app.
  • Click on Apps.
  • Select Google Play Store from the list.
  • Click the Force stop button and confirm. The application is now forcefully closed.
  • Still in the same window, click on Storage.
  • Click the Clear cache button.
  • Now reboot your phone and try again to see if the problem went away.

Possible resolutions to the [DF-RPC-01] ( Remote Procedure Call Failure error)

Well certainly I too believe it has nothing to do your device, even a lot of people have complained about the issue:

Based on the following evidence;

  1. Google Play Help Forum

    • It is usually occurring when there is no payment method linked to your account (as suggested on Google Play Help forum). Users have noted it appears to be a back end issue with Google.

    • You may wish to check your current payment options including any updated information such as address, payment choices (especially credit cards because of late Google has beefed up its security on use of credit cards for making app purchases).

    • One user did resolve the problem by reactivating the Credit card which had been blocked due to the suspected tampering. The incident is described here: How to resolve "Error retrieving information from server DF - RPC - 01" on the android phone? .

    You may need to contact Google support to present your query.

  1. From the above discussions this error is said to be different from other errors which are normally fixed by clearing data, clearing cache or updating google play services, based on evidence above.

  1. Strangely some users claim the problem was caused by having several google accounts on the device some of which weren't linked to Google Play and removing these extra accounts resolved the problem (however I don't think it’s too convenient but if that’s the only way out then it’s worth a try).

    • Opening up settings
    • Navigating to accounts settings
    • Selecting "google accounts"
    • Delete all unnecessary accounts
    • Re syncing all accounts and making sure none of them fail to sync properly because the device doesn't notify of any failures.

Update 1

For some reasons, it can happen that checkin expires. Here are some independant tricks you can use to force new device checkins: Google Checkin is the service responsible for “checking in” to google servers (also readies important updates and syncing of data(dropbox etc))

  • Compose ##2432546## (which stands for ##CHECKIN##)

  • If you don't want to dial or can't because there is no dialer on your device, use an ADB shell as root and type this:

    # am broadcast -a android.provider.Telephony.SECRET_CODE -d android_secret_code://2432546

Somehow this fix helped me fix one of the infamous errors: "Error retrieving information from server. [RH-01]" Which is the reason I am attributing the issue to be related to syncing issues with Google servers.

Update 2

  • Check if debit/credit card(s) have expired. When these cards have expired you can longer be able to make new purchases and this error appears so you need to renew/reactivate these. After which you need to enter new details.

When entering new card details make sure you clear cache of play store and google play services:

Settings >> Applications >> Google play store :Force close >> Clear cache/data

Settings >> Applications >> Google play services : Force close >> Clear cache.

Reboot device, then when re-opening Google Playstore you made need to reenter details (account with payment info). Afer successful sign-in you should see your billing info.

Error retrieving information from server [DF-RPC-01] While making IAP

Google Wallet

  • If you are using google wallet check if you not accidentally disabled the payment services. You can add debit cards or link bank accounts to your Google Wallet. Fore details see here: Add, update, or delete a debit card

    Make sure your google account address is the same as the address you had your my google wallet payments

Possible syncing issues between google play store and other google apps

Other workarounds : Using VPN connection

Through some seroius experiments, one user claims that after changing the connection and using VPN tunnel solved the issues with this error. Getting error [DF-RPC-01], cannot purchase apps or in-app purchases

Remarks: I myself have not yet encountered this error, but other minor errors which were resolved by basic troubleshooting (i.e. clearing cache, data, and updating google apps),

however have taken time to research on possible fixes and from my understanding this kind of error is likely to be related to Google itself, based on the evidence that it still appears on web interface apart from device. Hope that helps.

References (Some Included in body text)

  • Thank you for all the trouble, I have tried everything, but as far as I see it, only way is to contact Google support, which is impossible in my country, because support it is equivalent to zero.
    – Bojan
    Apr 12, 2017 at 8:58
  • @ghost I am sorry it turned out that way, my other suggestion would be perhaps using another account and link to google wallet for purchases. As it seems the current account is somewhat frozen. But before that, did emailing prove futile? Apr 12, 2017 at 9:04
  • Unfortunetly, I could not find anything accept US phone number
    – Bojan
    Apr 12, 2017 at 9:18
  • @gost I been busy trying to find other contact details - its a pity that Google support is not as professional as it ought to be, however I bumped into this article with a collection of details: How to contact Google.Check if it works Apr 12, 2017 at 10:49
  • I purchased VPN service, and contacted Google via US server. They told me my account was disabled, and they fixed it shortly. Thanks for all the trouble
    – Bojan
    Apr 20, 2017 at 15:57

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .