1

I've been facing the issue of missing alarms for a week. I can set alarms successfully, it displays in notification but not running.

Though if I try to check it will have work or not by setting alarms after 1-2 minutes, then it works ok. But if I set alarm before sleeping then it doesn't ring on morning.

One another thing may be related: I'm getting "Unfortunately clock has stopped" alert randomly about 2-3 times in a day (though it is not happening exactly while setting alarms).

So, I'm not getting what's going wrong with alarms. How can I recognize the issue and fix it?

Note: Running (non-rooted as running under time period of warranty) Android 6.0 on Lenovo .

6
  • Not sure, but could it be you've "dozed" the alarms app (or something related)? Btw: Never heard there's an Android 6.20. Must be something Lenovo specific :)
    – Izzy
    Jan 9, 2017 at 13:18
  • @Izzy I've disabled only calculator (also "force stop" would not be case as I've tried reboting several times). Btw was typo.
    – Pandya
    Jan 9, 2017 at 13:33
  • 1
    Could you be specific about your device model? Are you using only the stock Clock app? Have you tried clearing the data for that app? Jan 9, 2017 at 13:56
  • @MatthewRead Lenovo A6600 Plus. Yes, using only stock Clock app. Ok I've cleared data now let me check for next alarm.
    – Pandya
    Jan 9, 2017 at 13:58
  • @MatthewRead Clearing data worked. Now alarms are working fine and "unfortunately clock has stopped" message has gone permanently!
    – Pandya
    Jan 11, 2017 at 11:56

1 Answer 1

1

Try clearing the data for your Clock app.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .