5

Microphone icon is missing from gboard, is present in other keyboards(Swype, samsung keyboard), doesn't have a toggle setting under gboard settings. I have tried uninstalling gboard, didn't fix. What do I need to do to enable this or troubleshoot the issue?

2
  • What languages are you using? Does this happen on all text fields? I observed that the "G" icon and microphone won't show if the text field doesn't support text suggestions. Otherwise, you might have to manually change the keyboard to "Google Voice Typing" using the globe icon, if enabled.
    – Andrew T.
    Jan 10, 2017 at 5:36
  • Be aware that, as of Oreo onward, if you allow the Google app to have microphone permission, your phone is actively listening to you any moment that it is on. Thanks a lot, google! fuckers..
    – Alkanshel
    May 1, 2018 at 2:42

4 Answers 4

6

You must have uninstalled "google" app. Install that and then in settings go to languageand input option. There you have to select google keyboard and Google Voice.

3
  • That was it for me - after installing a custom ROM, I hadn't installed the Google app. I also had to go to Apps -> Google and and enable the microphone permission for the app. Oct 15, 2017 at 10:46
  • 2
    I found this to work: Languages and Input > Virtual Keyboard > G-Board > Text Correction > Show Suggestion Strip - change to on. Microphone instantly restored.
    – Barry MSIH
    Mar 13, 2019 at 14:06
  • @BarryMSIH You should put your comment into answer. Your suggestion is the correct answer
    – Thaina
    Dec 12, 2019 at 14:12
1

To fix, in SETTINGS, select go to language and inputs, select "keyboard and input methods," then "current keyboard," then "change keyboards" then "choose Keyboards" then toggle the "Google Voice Typing" to on.

1
  • OP said they had already tried that. I had the same problem and had to install the Google app. Oct 15, 2017 at 10:38
0

Go to gboard settings > preference > voice input key. Enable it.

Do keep in mind that it is available for some languages only and in supported text fields only.

0

The best and easiest solution is to go to Settings > apps > gboard, then tap on it and toggle the voice texting option.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .