I've had my Galaxy S2 SGH-I777 (AT&T) for about 2 months now and everything has been great up until yesterday. I started experiencing some freezing and strange behavior. The phone is unrooted and using the stock ROM.

The problems include but are not limited to:

  • Random freezing when the phone is locked (by pressing the power button). Always have to do a hard reset.
  • Random notifications about MTP initialization when no USB cable has been plugged into the phone.
  • Vlingo Voice command (come preloaded on the phone) randomly popping up/starting without anything being pressed.
  • Sometimes when I power off the phone it doesn't actually turn off completely but just restarts.
  • Plugging in the USB cable while the phone is off turns it on (I don't think this is default behavior).
  • And just recently I've had some strange touchscreen issues. Random letters being typed that I haven't touched etc.

These issues are not constant but occur intermittently. I've already performed a factory reset, but the problems persist. Since I have yet to read about anyone else having similar problems with their phones, this leads me to believe that it's not actually an issue with the stock ROM but an issue with the phone itself and the hardware. But before I take it back to AT&T I wanted to get some input from you guys. Any ideas on what could be causing this?

Thanks in advance.

4 Answers 4


I am also a user of Samsung Galaxy S2. Mine is rooted but all the indicators of your phone are pointing to a hardware problem. There is most probably a short-circuit like instantaneous electric jumps inside the motherboard. Most of your problems can be answered rationally by uncontrolled electric jumps.

For instance plugging the USB cable (namely a power source) directly starts the phone, indicating that there is a short circuit which transfers the USB power to the power button of the phone whereas they should be insulated.

When you power-off the phone, it restarts. This may be explained with a short-circuit of the phone's battery with the power button.

So on and so forth...

  • This is my inclination as well. Guess I'll be visiting the AT&T store again.
    – EricM
    Dec 8, 2011 at 2:02

I am experiencing the same exact issues here with an AT&T Galaxy S2 bought Oct 26 at Best Buy. I did root and have tried various ROMs along with returning to bone stock with no help. I have called AT&T for replacement but I have found 2 possible solutions in my research on the internet:

  1. I saw a random post somewhere about a user who tried CM7 (Cyanogen Mod 7) ROM and for whatever reason. It has rendered my phone very usable with none of the above issues for a few days now. For curiosity, I switched back to another ROM I had used before, and the problems came back immediately. Needless to say, I'm not sure why CM7 did any good.
  2. I also came across a post suggesting to use a small paintbrush and rubbing alcohol to swab out the USB port area. Several users reported success from this. I have not tried this yet but plan to.

I had this problem recently and found out that I just have to clean my USB port.


I have had this issue for a couple of months now with the whole MTP connection when I have not plugged it in. Turns out I just needed to clean the USB port on my S2. It had its little fit of unplugged/plugged in while I was cleaning and stopped once cleaned.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .