0

I use AdAway to modify my hosts file with quite a few aggressive sources. Unfortunately when my filters are active I can't see any channel or user pictures in the YouTube app. I can't figure out what hostname(s) I need to whitelist to fix this.

I've tried using the tcpdump log to add a bunch of Google/YouTube hostnames but this hasn't worked and I don't understand why. Any help would be appreciated.

2

I finally resolved this on my own. After lots of DNS logging I found the necessary. hostnames.

  • s.youtube.com
  • s.ytimg.com
  • youtubei.googleapis.com
  • yt3.ggpht.com
  • 1
    Which are? Others may benefit from your list... – Michael Kohne Jan 16 '17 at 20:26
  • 1
    I certainly hope so – Jesse Jan 16 '17 at 20:37
  • brilliant! i had installed adaway on a rooted galaxy s3 running 4.3, and the audio on youtube videos was either gone, or sounded garbled. (youtube's ads had perfect audio) i whitelisted the 4 entries you discovered, and youtube audio is back. – B R Feb 20 '17 at 3:22

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.