1

I have a Samsung Galaxy S5. A few weeks ago, my video camera stopped working. Every time I press the video button, the following message appears:

Security Policy prevents video recording

I have tried every recommendation, but I am still seeing this notice.

How can I get rid of this issue to record again?

3
  • 1
    Do you have an Exchange or corporate email account on your device?
    – acejavelin
    Commented Jan 12, 2017 at 2:23
  • @AbandonedCart AFAIK, the Security Policy will prevent the feature completely, so I don't think it's possible to get rid of the notification and record a video without disabling/bypassing the policy altogether. But fair point, perhaps there's a way to do it without disabling it.
    – Andrew T.
    Commented Jan 7, 2020 at 2:07
  • @AndrewT. Even so, it should be left to the person answering to decide if that is the best route to take without changing the question to ask for it. 90% of the time a question seems to have such an obvious process, that is the process that was already tried and failed. Commented Jan 7, 2020 at 2:43

2 Answers 2

1

A Security Policy can come from a few different sources, so it depends on where yours originated.

If it is a company device, you may not have any options without asking for permission.

If you have a Microsoft Exchange account, you would likely need to remove the account.

If it is your personal device and you do not have an Exchange account:

  • Go to Settings -> More -> Application Manager (or Settings -> Apps on Samsung)
  • Select the All item
  • Scroll down and tap on Security Policy Update
  • Press Force Quit
  • Press Clear Data
  • Restart your phone

Credit for this process goes to skippybosco's reply on reddit

2
  • on Samsung phone there is no provision to select all apps and further the said steps....
    – Shamshu
    Commented May 13, 2021 at 4:48
  • @Shamshu Not entirely sure what you were trying to post, but this process may not apply beyond Marshmallow (the last version for an S5, per the question) Commented May 13, 2021 at 6:22
0

Check if Sensors Off is enabled on the quick settings panel.

It might also be a reason why your camera won't work.

3
  • I don't see this button on Pixel 3a. Is this on Samsung (as per question)? Otherwise, could you mention the device model and Android version?
    – Andrew T.
    Commented Jan 31, 2022 at 16:48
  • I'm using Android 12 on Galaxy Note 10+. However, it needs developer mode to be visible.
    – AbuSaad
    Commented Feb 1, 2022 at 17:16
  • Ah, I see, thanks for the info. Apparently, it's also available on Pixel 3a, Android 12. I just did some tests with this setting and video recording, and while it's true that I can't see anything from the camera, I didn't get any message about "Security Policy". Though, I don't know if it behaves differently or not on Samsung/other devices.
    – Andrew T.
    Commented Feb 1, 2022 at 17:34

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .