I installed CM 14.1 on a Nexus 6 and the first update booted into TWRP automatically to install but failed.

I manually installed the zip from the cmupdater folder and rebooted.

Now every time I try to reboot my phone or power it on from powered off it goes straight into TWRP.

Currently I have to boot into the bootloader and choose the Start option to get into my system.

Tried clearing dalvik/cache & internal storage in case something was cached somewhere. No dice.


Since you've already cleared your internal storage, I assume you backed up your important data already. In that case, flash a factory image and get a fresh start.

Just don't do CM updates via the built-in updater, it's designed to work well only with CM Recovery (which is pathetically weak).

EDIT: From your feedback it seems CM Recovery is what's required to finish the update (or at least get you out of the process). Just flash it and boot into it. Replace it with a recovery of choice later.

| improve this answer | |
  • I'd definitely prefer to hold out on a solution that doesn't require a factory reset. That being said, you did make me think to actually just flash the CM Recovery temporarily and do a few reboots. First reboot went into CM Recovery. Booted back into system and flashed TWRP again with Flashify & rebooted once more. Phone successfully rebooted to the system instead of TWRP. If you change your answer to reflect this then I'll accept it. – Enigma Jan 15 '17 at 0:33

Mammuth's comment points to a very simple solution that worked for me, once I adjusted it. Here's what I did:

Go to TWRP recovery terminal commands, and enter the following:

First navigate into /dev/block/platform/soc/:

cd /dev/block/platform/soc/

Now take a look at the contents of that folder by typing:


If all is well, there will be a subfolder named xx.sdhci, where the xx is a string of numbers, e.g. 7464900.sdhci.

Now issue the following command, taking care to replace xx.sdhci with the folder name found in the previous step:

dd if=/dev/zero of=/dev/block/platform/soc/xx.sdhci/by-name/misc

Finally reboot by typing:


This fixed it for me. I hope it works for you as well!

| improve this answer | |
  • 1
    This worked for me. Being lazy by nature, I found out that you can use "adb shell" command to easily browse and type the command (instead of typing it in TWRP which is not easy to do). – Sup3rHugh Jul 11 at 22:48
  • WARNING: don't use this solution, it caused to brick my phone! – Al-Mothafar Sep 30 at 11:49

If you can access twrp i sugest to download the last cm version from web and install it doing the same method that used to flash cm for the first time, not update, install gaps and see if boots into cm.

| improve this answer | |
  • Just tried this. Unfortunately it did not resolve the issue. – Enigma Jan 14 '17 at 21:41

I had this problem on a Motorola Moto Z.

Here's how I fixed it:

  1. Make sure fastboot is installed on your computer
  2. Boot your phone into bootloader (usually by holding volume keys while powering up)
  3. Connect the phone to the computer via an USB cable
  4. Issue the following command on your computer: fastboot oem fb_mode_clear
  5. Power phone off.

The next time the phone should directly boot as usual.

| improve this answer | |

This usually happens when the ROM is not installed properly, try flashing the factory image and start over the process again, install the latest vendor firmware(if there's one) and install the latest TWRP and then flash the ROM file, In my experience you don't have to wipe the internal storage every single time if your device is not encrypted, just the system, data, Dalvik/ART Cache, is enough.

| improve this answer | |

I have LineageOS. And an a/b device, and what i did fixed it for me. Basically i switched from A partrition to B throu twrp then i rebooted

| improve this answer | |

Not the answer you're looking for? Browse other questions tagged or ask your own question.