0

I have a Motorola Turbo 2 Android. It won't turn on. It just stays on the Power By Android screen. I have tried turning it on by holding the volume up and power buttons. The screen shots up but I get lost at this point. It does not give me any option to start.

Now going from the Powered By Android screen... on and off.

What must I do to turn it on?

Might I be over charging it?

  • 1
    Hold down the power button for a while! It'll turn on. Comment back @owlswipe if that doesn't help. – owlswipe Jan 15 '17 at 21:53
  • I tried that several times. It did not work. – SharePointNY Jan 16 '17 at 1:08
  • Next step: go into recovery mode and clear your cache. Let me know if that helps. – owlswipe Jan 16 '17 at 1:12
1

Seems like your phone is soft-bricked. You'll need to hard reset it.

  • Begin by switching off the device by holding down the Power key for a short while.

  • In the next step press and hold Volume Down + Power button simultaneously for a few seconds.

  • Press the Volume Down to select option "Recovery", and press the Power button to confirm.

  • When the Android bot shows up on the screen, hold down the Volume Up for a couple of seconds.

  • While holding the Volume Up hold down the Power key and after a short while release all buttons.

  • Afterwards press Volume Down to choose "wipe data/factory reset", and then push the Power key to confirm.

  • Select "Yes--delete all user data". Use Volume Down button to scroll and Power key to select.

  • To restart the tablet, select "reboot system now".

Your phone should boot normally.

Note that after a hard reset, the first boot takes several minutes, so be patient.

Please comment down if something goea wrong.

  • Will I use all my contacts in my phone if I do the "Yes--delete all user data"? – SharePointNY Jan 16 '17 at 1:09
  • It depends on where you have saved them. Do you have a Google backup for your contacts? – esQmo_ Jan 16 '17 at 1:12
  • @SharePointNY Try doing what esQmo said except do a wipe of your system cache (which won't delete your data like esQmo's plan will) instead of a deletion of all user data. Clearing your system cache should allow the phone to boot up. – owlswipe Jan 16 '17 at 1:12
  • I am trying the directions above. It's not working yet. – SharePointNY Jan 16 '17 at 2:02
  • @SharePoinNY Where are you at? – esQmo_ Jan 16 '17 at 3:02

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.