1

A few weeks ago my Xiaomi phone (MIUI 8) started showing a permission error, stating that more permissions are necessary. After enabling all of them, the error reoccurred after a few minutes, this time asking for other (previously enabled) permissions (mostly body sensors, storage, sms, etc).

It is somewhat annoying, since I get a notification every few minutes with the same error, which wakes up my screen. How can I fix this problem and make sure the permissions are always enables?

screenshot

5
  • Try disabling Google Play Services and reenabling? Try clearing its cache? Force quitting it?
    – owlswipe
    Jan 15, 2017 at 21:50
  • @owlswipe I did, and I also uninstalled all updates from google play services and framework and re-installed it (from here: mobipicker.com/…). I haven't tried a factory reset yet. Is there another way?
    – DK2AX
    Jan 16, 2017 at 16:19
  • Try clearing the data cache of the Google Play Services app (Settings -> Apps -> Google Play Services -> Storage -> Clear Cache and/or Clear Data) and then try clearing your system cache. And can you check for software updates?
    – owlswipe
    Jan 16, 2017 at 16:44
  • @owlswipe Ha, I removed my google account, restarted the phone, logged back in and then cleared the cache as you advised. For an hour now there hasn't been such an error message, it seems that fixed it. Thank you! You could put this into an answer so that I can accept it and close the question.
    – DK2AX
    Jan 16, 2017 at 17:42
  • Happy to help! Answered below, and if the issue comes back, feel free to comment back and I'll keep trying to help :D
    – owlswipe
    Jan 16, 2017 at 18:53

1 Answer 1

1

This issue seems to me like a bug with Google Play Services, probably caused by some of your data within the Services app given that this isn't happening to everyone. Try these steps in order until the issue is resolved:

  • Check Google Play Services for an update in the Play Store, and if available perform it.
  • Force Stop Google Play Services in Settings -> Apps -> Google Play Services -> Force Stop.
  • Log out of your Google account.
  • Restart your phone.
  • Log back into Google Play Services.
  • Clear its data and/or cache in Settings -> Apps -> Google Play Services -> Storage -> Clear Cache/Clear Data.
  • (According to OP, not necessary): Clear your phone's system cache.

Note: See OP's comments above for how they fixed the issue.


Happy to hear this helped!!

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .