2

I mounted my NFS shares successfully in Termux with busybox. I mounted the network folder to /data/media/0/Music.

I'm also able to see the content of the network share in the terminal with ls -l /data/media/0/Music. But when I click the location in my file manager the location is empty. I tried different file managers as well but all display nothing.

Is is a permission issue? What do I have to change in Android to make it work?

  • Did you create that mount as root? Then it might very well be a permission issue. What does ls -l /data/media/0 | grep Music show on ownership and permissions? – Izzy Jan 17 '17 at 19:55
  • ls -l /data/media/0 | grep Music says drwxr-xr-x 16 system system 4096 2016-08-27 20:58 Music. I tried 2 ways to create the folder Music. 1. In File Manager as a normal user. When I was trying to access the folder after mounting I got a permission issue. 2. I created the folder in the termin as a root user. In that case the folder is displayed as empty in any File Manager. – AndRoot Jan 17 '17 at 20:10
  • OK, that says the folder is at least readable by everyone, and everyone can change into it (plus it belongs to the system user and group). Now please repeat the same with a minor adjustment: ls -l data/media/0/Music/* and pick a single entry from the output. If it has the same ownership (system), it should at least have 3 times "r" in it so other apps can read it. – Izzy Jan 17 '17 at 21:21
  • All files in there have ownership system and all files have 3 times "r" in their permission properties. They should be readable by owner, group and others. But still I can't see any files in a File Manager or Music player app for my nfsv4 mount. – AndRoot Jan 18 '17 at 12:31
  • Not seeing them in the music player could have to do with the media-scanner not having them picked up (yet). Nevertheless, that should not affect file managers, which confuses me. Have you tried 1) different file-managers, 2) examining that directory in a terminal with a non-privileged user (e.g. via adb shell as the "plain shell user")? – Izzy Jan 18 '17 at 13:00
1

Turns out an option in SuperSU blocked me from seeing the content of my mounts. I needed to disable the "Mount namespace separation" option in SuperSU app. Only then the mounts will be visible to other apps! Disabling namespace separation may cause security flaws, but I don't see any other solution yet. Reboot the device, mount your shares and everything will be as expected.

Found the solution here: https://stackoverflow.com/a/33611664

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.