3

So recently, I started using Android 6.0, and one of the first things I noticed was that the external SD card was no longer mounted under /storage/extSdCard anymore; instead it was mounted under a folder named after the Volume ID in /storage, meaning that several of my applications that originally used the /storage/extSdCard path could not anymore. I was curious as to whether it's possible for me to create a symlink in storage to the new path named /storage/extSdCard so that those applications can still use it, but when I tried using ln -s /storage/some-volume-id /storage/extSdCard to create the link, though, the result ended up being only visible and usable as the root user. I checked the permissions which saw full rwx permissions for all, tried changing the group to match the others, tried the symlink switch on the commands, and tried remounting filesystems read/write, but the link still doesn't work for any of the apps or non-superusers. I'm still relatively new to this, so is there anything I'm overlooking that somehow keeps the link from showing up?

0

Did you upgrade to 6.0 over-the-air? You may need to flash a fresh installation if you intend on keeping your phone unrooted. I've never heard of anyone being able to create symlinks/modify mount points/etc. without root. But maybe someone will come along here who knows more than I do.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.