After doing a factory reset of my phone, I'm trying to set it up and going through the initial steps. After logging into my google account, the next page shows options for restoring the phone using a previous backup. Before I can choose any option, a message appears saying, "Unfortunately Google Play Store has stopped". I have no option but to press ok, this then returns me to the previous screen. I can't get passed this step. There are solutions to the google play store issue but they involve changing settings on a setup phone. Can anyone help?

  • Model? Rooted or not?
    – Andy Yan
    Jan 22, 2017 at 9:29
  • Moto G (2nd gen). Not rooted
    – FinDi
    Jan 22, 2017 at 10:11

1 Answer 1


Solved! (sort of). I was trying the setup on WiFi. When I tried outside my house on data, it then followed different steps and Im now in my reset phone, so I should be able to follow the normal process from here.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .