0

My Sony Xperia M5 is not booting up. The screen is off, no LEDs are lit, it doesn't react to any buttons. It already happened several times. I wasn't doing anything specific, just was using it normally, and then suddenly it would hang up. This last time it happened while it was charging.

  1. After about 9 months of usage, it went into a boot loop, which I was able to resolve by switching it off/on (with a hidden power button). It took several attempts, though.
  2. About 2 or 3 weeks later, it went into a boot loop again. This time switching it off didn't help, so I tried resetting the firmware using the official tool from Sony. It didn't help either, so I brought it to the after sales service. They updated the firmware, and it was enough to fix it. They wrote that "the defect was not found" in their report.
  3. After 2 or 3 weeks, the phone stopped working at all: the screen is off, not responding to any buttons, including hidden power button and combos like power+volume up/down. Again, brought it to the service, with the same result: resetting firmware helped, but "the defect was not found". This time they did some "WRT test" (no one has any idea what it is exactly), which was fine too.
  4. Now, again, after 2 or 3 weeks, same happened - not working at all.

Phone condition is fine and I used it properly:

  • It hasn't fallen once, didn't contact any water, was not affected by extreme temperatures, (electro-)magnetic fields, radiation, etc.
  • Viruses are pretty much excluded: it had an antivirus installed, I only used apps from Google Play, and only the ones I trusted. I don't use any Wi-Fi spots outside of my home and office.
  • The battery is fine.

Now, I just want my money back, but the only two documents I have on hand say that the device is perfectly fine, so the shop will refuse it. I want something to prove the defect is actually there. My questions are:

  • What kind of problem can it be? If it's a hardware problem, why would firmware reset fix it? If it's a software problem, why would it even occur? My only idea is that it's a memory failure, but there was no indication of that when I did the firmware reset (I assume it should do at least basic tests).
  • Is there a way to perform any conclusive tests by myself? I talked to managers in the service center, and they pretty much don't care. I have to chance to talk to engineers directly. I won't open the case or anything like that, and also now it's doesn't load at all, so the only options is to use some software on PC, with a USB cable. Is there any software for that?
  • 1
    The problem is probably hardware related. The eMMC chip might be defective causing data damage. You can use Androxyde Flashtool with a firmware in .ftf. Boot in flashmode (Plug USB cable while holding volume down button). – esQmo_ Jan 25 '17 at 14:58
  • @esQmo As I understand, with that tool I will be able to restore the firmware, but that is not what I want. Instead, I need some kind of proof that the device is actually defective, so that I could convince the guys from the service (or the store's warranty department) to at least perform a proper expertise. Otherwise, they will just reply with "the defect not found" again. At this point I just want my money back. – scriptin Jan 25 '17 at 20:24
  • There is no tool at my knowledge that can perform some checking and give proof of a defective hardware. And if the issue was a result of your behaviour, the manner you use the device? – esQmo_ Jan 25 '17 at 21:32
  • I was very careful, as I explained in my question. Well, as I expected, there may be no solution to this problem. Thank you anyway. – scriptin Jan 25 '17 at 21:54

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.