I'm trying cyanogen's mod approach to root my Defy. I can do adb shell, it works as intended. But after I run adb kill-server and try an adb shell I get

error: device not found

It seems my phone just decides to not be connected anymore when I call kill-server. I need to physically reboot it and start everything again.

This is the complete command session I did:

[~]$ adb devices
List of devices attached 
0A3AA8D5195599849BN device

[~]$ adb shell      
$ exit
[~]$ adb kill-server
[~]$ adb start-server
* daemon not running. starting it now on port 5037 *
* daemon started successfully *
[~]$ adb devices
List of devices attached 

[~]$ adb shell
error: device not found

This is driving me nuts. I've searched about this problem, but there simply isn't a solution in entire Google's database. I want to use this rageagainstthecage root approach because I can see the exploit source, I'm a little nervous about using something in my personal phone that I don't know what it does (an explanation about rageagainstthecage, and a compact explanation)...

Anyone here at SE network have seen a similar problem - or have a suggestion?

I'm doing this in a Macbook Pro machine (OS X 10.6.8). My phone has Android 2.2.1.

(PS: Even without using the exploit, just doing adb kill-server and adb start-server, my cell phone isn't shown anymore on adb devices, thus receiving error: device not found. So this seens to be a problem with adb kill-server)

  • 1
    do adb start-server after killing it. Dec 10, 2011 at 10:49
  • Instead of doing kill-server, try going in to Settings -> Applications -> Development and turn off USB Debugging, then turn it back on Dec 10, 2011 at 15:33
  • @PadmaKumar When you run adb devices, it automatically starts the server. So, if you try to run adb start-server before doens't matter, you receive the same error: device not found. Dec 10, 2011 at 16:06
  • @RyanConrad this doesn't work either... Even if I remove the usb cable, it doesn't detect after I call adb kill-server. I have to physically reboot my phone. :/ Dec 10, 2011 at 16:12
  • I missed this before that you have the motorolla defy. This runs BLUR and I have always had a hard time getting adb to find a BLUR device. I had to switch the different USB modes to get it to find it. Dec 10, 2011 at 22:57

5 Answers 5


I had the same problem (Rom: 34.177.3.MB525.Retail.en.DE). The only rooting method that worked was Gingerbreak ( http://project89.com/root-defy-without-pc-gingerbreak-200/ )

  • Well, thanks for answering about another exploit working. I believe SuperOneClick used gingerbreak as well, since it uses a lot of different exploits to accomplish the root goals. Jan 11, 2012 at 0:15

i'm late to the party but in case anyone googles this and finds it - my own experience of this is solved if you perform the rooting without an SD card in the phone

that way windows doesn't mount the phone and get in the way


I had the exact same setup and problems described by @"Somebody still uses you MS-DOS". I'm using a mac 10.6 and trying to root Motorola Defy following the Cyanogen's wiki and using rageagainstthecage to root.

The wiki suggests using "psneuter" to gain root. Instruction below come from the RootzWiki.

Download latest version of psneuter, and extract. Then run the following ADB commands

./adb push ${LOCATION_OF_PSNEUTER_BINARY}/psneuter /data/local/temp/psneuter
./adb shell
chmod 755 /data/local/temp/psneuter

ADB should hang, wait a while and then type

./adb shell

If you see a '#' sign instead of the '$' then you have temporary root.

  • Hum, I believe the psneuter wasn't available as an option when I read the wiki. Thanks for this information, it might be helpful for someone in the future! Nov 23, 2012 at 1:11

Try running adb start-server using sudo.

On my ubuntu machine that I use as my test environment, I always need to start adb service using root.

  • This isn't a problem with Mac OS X, since I already run these commands and can use them without problem (they're installed using homebrew), but thanks anyway. (I've already come across this hint about sudo on pocketmagic.net/?p=762) Dec 11, 2011 at 2:33

This isn't exactly an answer to this question, but to the exploit itself: I just became fed up after two days of suffering. I used a tool named SuperOneClick and in 10s it rooted my phone.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .