0

After making a 1744MB ext2 partition on my 4GB MicroSD with the Aparted app (since my Windows SD slot is broken) and trying to select ext2 when I start Link2SD I always get the error:

Mount script cannot be created

mount: Invalid argument

I tried to delete busybox from system/xbin to install a newer version, but /system won't mount as Read-Write. How do I fix this?

EDIT: I'm using KingRoot

EDIT 2: So I made an ext4 partition instead, and now it says

Mount script cannot be created

mount: Read-only file system

and I tried running e2fsck -fpDC0 /dev/block/mmcblk1p2 in terminal emulator (seen here as a solution) and I got the output:

<5> e2fsck: Internal SD card is not found, now mount manually <3>e2fsck: save_log_to_file error /dev/block/mmcblk1p2: |== /dev/block/mmcblk1p2: |============================= /dev/block/mmcblk1p2: |=============================

/dev/block/mmcblk1p2: 12/116400 files (0.0% non-conti guous) 16193/465096 blocks

  • Try using ext3 or ext4 filesystem – Wh1t3 Ni9ht Jan 26 '17 at 17:57
  • It shows up as ext2 in Aparted, and it didn't work in Link2SD when selecting either ext2, 3, or 4. – kprovost7314 Jan 26 '17 at 19:04
  • EDIT: It's showing up as ext3 now. – kprovost7314 Jan 26 '17 at 19:11

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.