3

I picked up a second-hand Motorola Moto G (2nd gen) device. The model is technically XT1064 (Titan).

On my Windows machine, I'm sometimes able to see an error message when I power down the phone stating that the USB device was unrecognized (Device Descriptor Request Failed).

After days of trying, I've yet to have it show up in adb. But it works just fine if I boot into the bootloader and run fastboot commands!

I've tried all of the "easy" things people recommend:

  • enabling USB debugging under Developer Options
  • different USB cables (although since fastboot works fine, that implies the cable is also fine)
  • different computers (tried a Mac, a Windows 10 machine, and a Windows Vista laptop)
  • adb kill-server followed by adb devices
  • various adb versions (Android SDK platform tools and Universal ADB driver)
  • manually uninstalling Windows drivers
  • force installing drivers (doesn't work, since the device doesn't make it past the device descriptor request so Windows won't allow drivers to be installed)
  • installing the Universal ADB driver
  • re-flashing the device (tried stock Marshmallow, stock KitKat, and Lineage OS)

I'm frustrated by the process because fastboot works just fine. That's how I've flashed the separate ROMs on there.

If this were a hardware issue with USB, why would it be that fastboot operates correctly but adb does not?

Also, if it's a hardware issue, what physical part would be the problem? It seems unlikely to be the USB port itself (again, because fastboot works just fine). Is there some kind of USB controller in the phone that could be the issue? Since the device is pretty useless to me unless adb works, I'd entertain the idea of trying to solder in a new part to fix the problem if I could!

2

If your device is rooted, you may set up adb over network as a workaround for all USB driver problems.

  • Make sure both PC and Android device are in same network
  • On Android, install Terminal Emulator
  • Open Terminal Emulator and type the following:

su
setprop service.adb.tcp.port 5555
stop adbd
start adbd

  • On a PC side, enter:

adb connect 192.168.1.2

(replace 192.168.1.2 with the IP address of your device)

  • Proceed with adb as if it was connected over USB

Alternatively, you may create a script with GScript instead of using Terminal Emulator.
Also, you can add these lines to your Android boot scripts, in which case you don't have to do it manually every time.

  • This is actually exactly what I ended up doing! I didn't need to root the device -- I just installed LineageOS and it supported it right out of the box. I just use adb connect and everything works fine. Although this is a great workaround, I'm not sure it's a solution to the problem. But it's definitely what I did, so I upvoted you. Thanks for the great suggestion! – aardvarkk Feb 5 '17 at 5:57
2

You may need to enable USB Debugging enabled

To enable follow these steps:

  1. Open settings
  2. Open Info
  3. Find the Build Number and tap on it alot until it says You are now a developer!
  4. Exit Info
  5. Open Developer options
  6. Tap on USB debugging
  7. Tap on OK

Notes:

  • In 4.1.x and before skip steps 2-4
  • In 2.2.x and before goto Settings->Applications->Development->USB debugging
  • Sorry, I should have added that to the list of things I've tried :). Doesn't work! – aardvarkk Jan 27 '17 at 0:03
  • @aardvarkk it's OK, I would have commented asking if you had, just to make sure, but I can't comment yet so... I made an answer about it – DanHolli Jan 27 '17 at 0:15
  • @aardvarkk, have you tried the device's default windows drivers? – DanHolli Jan 27 '17 at 0:15
  • Yeah, I installed the drivers from the original manufacturer. But I think it's a deeper issue since the device doesn't even get to the point of trying to use drivers -- it fails on the Device Descriptor Request. – aardvarkk Jan 27 '17 at 0:29
  • I'm not meaning ones you download, ones that Windows installs by itself – DanHolli Jan 27 '17 at 0:40
1

fastboot works, adb doesn't? my ans: you can use image loader which is compatible with that device,erase all the previous data and freshly build new Meta data by including the partitioning,after success u might get expected output like flatten success(related to build of that device).then adb will work fine with usb port detection.

hopes this works!

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.