0

So I LOVE the Textra app, but after I just upgraded to Nougat on my OnePlus 3T - I noticed that my text message notifications disappear form the notification tray on my main screen after a while. It used to be that they would stay in the notification bar until I accessed/dismissed them and then they'd disappear.

Now I get a message and it temporarily shows the Textra notification icon in the tray at the top of the main screen, but if I lock the phone without answering and then unlock again the notification disappears.

This is inconvenient because after a few hours away from my phone, I have no indication that I got any texts unless I remember to open up the textra app and see what's new. I liked it better before!

I couldn't figure out where to ask Textra directly - so I came here! Thanks.

  • Is it immediate after you lock the screen and unlock again, or is there some time in between? If the latter, it sounds to me like the app is getting killed by the system to free up memory. One possible fix might be (if you are rooted) to use Titanium Backup or another similar app to turn Textra into a system app, so that keeping it running will be a priority for the system. – Matthew Read Jan 28 '17 at 5:09
  • It seems to be pretty delayed, actually. And if I don't pickup the message right away or soon after I get it then the notifications disappear from my my notification tray. For example, I just had my wife send me a test one and it stayed there for a few minutes, but when I opened the Textra app I noticed I had text messages two other threads that did have notifications showing up in the bar. They must've come in during the last 15 minutes or so and the notification icons in the tray had disappeared without my ever seeing them. I'm not rooted - just normal OS. – dfree86 Jan 28 '17 at 15:18
0

I had the same problem. The Textra app includes a support section (settings > support) and this is one of the top topics. Here is the text.

OnePlus running Android 7 - Notification disappears / goes away

To fix, do Android Settings > Battery > Aggressive doze and app hibernation (dotdotdot top right) > set Textra to 'Not optimized'.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.