0

I am on a Nexus 5x running 7.1.1. Earlier today found no cards on the Google Now screen, just this message: "New Version Available A more recent version of the Google app is available for download". So tapped the link which took me to the Play Store and the Google App. Where there is no update available, just options to open or uninstall.

Hitting open loops me right back to the above message.

Fixes I have tried: Turning Now off and back on. Deleting card preferences. Uninstalling Google and the Now Launcher and reinstalling both. Turning location services off. Have also checked that Settings>account & privacy>Google activity controls>web & App activity is set to "On". Oh, and switching my phone off and on again :-) None worked. Any help would be greatly appreciated.

0

Just to let you know you're not alone.

too have exactly the same symptoms on a Nexus 5X running 7.1.1 I've tried:

  1. Leaving the beta program, removing Google App (beta) and installing mainstream Google App

  2. Google App Rejoining the beta program, removing Google App and installing Google App (beta)

  3. Deleting all cache data for Google App

  4. Rebooting the phone.

etc.

Nothing worked.

However, switching to an alternate Gmail account clears the problem. This account is not in general use and although registered on the phone was not active when the App was updated earlier on today.

I do not want to change the main account as I have a vast network of settings and content in the original, non-functional account.

0

I have the same issue with my "Google Account" Here's what I have noticed so far. Incidentally I got a replacement Samsung Galaxy S7 Edge yesterday and I noticed this issue after I completed the initial device setup. But it did work fine initially.

Here's what I have observed so far:

  1. This started happening around 9 PM CST.
  2. I signed up for beta testing to install updated version but that did not help.
  3. Reinstalling Google App, clearing app cache or android cache partition does not help.

  4. This issue is not specific to a device, it's tied to the google account. I see this on my original Samsung Galaxy S7 Edge (the one I am getting replaced under warranty), My wife's Galaxy S7 Edge(when I add my account to her device) and for that matter even on my Nexus 2012 tab.

  5. Adding a different google account resolves the issue. This is not an ideal solution though, since Google now cards are based on data from google account and using alternative google account will not show you cards which are relevant to you.

  6. Another possible solution, but it has limitations:

Navigate to Google App settings -> Account Privacy -> Google activity controls and turn on Web & App activity. Go back to google now cards and swipe down on screen to refresh. Google now cards start working and the "New version available" message is not seen any more.

Limitations: You will not get cards related to traffic updates, location, cards based on your web and app usage. This pretty much beats the purpose of using Google now cards.

Extremely frustrated with this issue. Hopefully there is fix available soon.

0

This issues seems to be fixed for me now. I added another google account and switched to it (only in Google App) for a while that was at least showing me the cards. Now I tried switching back to the the original account in Google App and it is working as expected. I still have the second account added though.

Now everything seems to be working fine. I an pretty sure this was at Google's end (server side) since no app update was pushed to fix this issue.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.