I downloaded ES File Manager and created a .nomedia file so that my WhatsApp images wouldn't automatically download into my gallery. But that sends ALL WhatsApp images to a hiding spot. Ideally, I want to select the images I want from WhatsApp and have those seen in my gallery. It seems there's no middle ground or way to do that. So, if I have to choose, I'd rather all media automatically go to my gallery and I'll delete the images I don't want. But I cannot figure out how to undo the "damage".

I finally located and "unhid" the .nomedia file, but I can't seem to send my pics back to the gallery or make them automatically go there.

  • 1
    Have you deleted the .nomedia file, then rebooted the device? Jan 30, 2017 at 20:51
  • Clear the MediaStorage "app" in Android Settings and perform a reboot.
    – crazo7924
    Dec 19, 2021 at 7:57

1 Answer 1


If all your WhatsApp images are located in the same directory, then I have to say that there doesn't exist a 'middle' solution. However, if those images lie in different directories (it's OK even if the directories are nested, i.e. one contains others), you can create .nomedia for them separately.

Please note that the 'effective range' of a .nomedia is the folder it is located in and all the subfolders under it. So if the directories are nested too complexly, the solution may not be very satisfactory.

To undo the effects of creating the .nomedia file you simply delete the same .nomedia file. Then force restart your gallery app or restart your phone.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .