I tried flashing my Acer Iconia tablet with Android Nougat (NMF26U), following the Google directions, but it failed during executing flash-all.bat.

What can or should I do to try and restore my device to any working state?

Terminal Output

target reported max download size of 134217728 bytes
sending 'bootloader' (32980 KB)...
OKAY [ 1.110s]
writing 'bootloader'...
FAILED (remote: partition table doesn't exist)
finished. total time: 1.120s
rebooting into bootloader...
OKAY [ 0.004s]
finished. total time: 0.005s
< waiting for any device >


The terminal hasn't updated since that, and the device shows no signs of life except it causes the Windows 10 "Device Manager" to update/refresh about once a second. This makes me believe that it's such in a fast bootloop, which causes problems mentioned below.

The device itself does not respond to any combination of button presses or holds, which may be a result of the fast bootloop not allowing the device to recognize longer button holds.

adb devices no longer sees the device at all, and neither does Windows. The screen remains completely black, and there are no indicator lights on the device.


I am unable to use the terminal or any other tools to recognize the device over USB cable, except for the "Device Manager" refreshes explained above. The buttons are completely unresponsive. I have tried disconnecting and reconnecting the battery ribbon, but the device returns to the exact state it was in before the hard power cycle.

1 Answer 1


Wait, you tried flashing the factory images for the Pixel XL (codename Marlin) to an Acer Iconia tablet?! Yeah, you cannot do that, you can't just flash any firmware to any device, this doesn't work that way.

You would need Acer to release their firmware for your tablet, the firmware you flashed is for the Pixel XL and is only meant for the Pixel XL. You may have bricked your tablet doing this. You maybe need to figure out/find your factory firmware for this (from Acer), and figure out how (...if?) it can be reloaded.

  • Thank you, before I started I knew that it most likely wouldn't work, and thought that the Acer distro of Android was so far out of date that it would be worth the risk to upgrade. I'll be reaching out to Acer later and seeing what they can do, but also keeping this question open in case y'all have different suggestions.
    – andrewgu
    Jan 31, 2017 at 20:18
  • Update: Acer refused to provide support without the SNID (now only obtainable from the non-existent Android settings)
    – andrewgu
    Jan 31, 2017 at 21:12

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .