7

I have a Samsung Galaxy SII Skyrocket. Everytime I unplug my headphones/auxiliary cord from my phone and plug it back in, the media volume gets lowered to about 60%, system-wide, regardless of media player. As much as I appreciate that Android is looking out for my hearing, I don't want it to do this. Any way to prevent the phone from lowering the volume of its own accord?

4
  • Maybe have a look in the settings of your media player. And more details would be helpful like: which media player? which phone? – joweiser Dec 11 '11 at 23:09
  • Updated with more detail. – joelmdev Mar 1 '12 at 19:38
  • There is a setting "Limited Headphone Volume" or something it should prevent too loud sound. You can toggle it in Settings->Sounds, i'm using CM10 but i'm not sure if it works on other ROMs(ie Touchwiz) – minicookie Sep 13 '12 at 15:21
  • @wayback no such luck on default ROM. – joelmdev Sep 13 '12 at 15:43
4

I'd say this is solvable with an automation tool like Tasker, Llama & Co. Rawly described profile:

Condition: Headphones plugged
Action: Set audio level to X

Where "audio level" in many cases (at least with Tasker) can be defined more specific (e.g. different levels for notification, alert, incoming call...) -- and "X" being the specific level you'd like it to have.

This done, everytime you plug your headphones in, you'll have the same media volume you've defined.

1

Here is how to fix the problem without root and without setting the volume to some predefined volume (such as 100%).

This "feature" is controlled by a System.Global property audio_safe_volume_state, which is also reset automatically every 20 hours (this is why the volume periodically gets lowered all of a sudden even without plugging / unplugging the headset).

This excellent tutorial shows how to prevent volume lowering by changing the value of this property.

I cannot repeat the tutorial here, but the main points are:

  • Install Tasker and AutoTools
  • Grant AutoTools WRITE_SECURE_SETTINGS permission (no root required, but this is to be done from a computer via USB debugging with ADB; the command is adb shell pm grant com.joaomgcd.autotools android.permission.WRITE_SECURE_SETTINGS)
  • Create tasks in Tasker (using AutoTools plugin) for start and for every several hours; you will probably need also to catch the event of plugging in a headset
  • In this task, set System.Global property audio_safe_volume_state to 2.

The value of 2 tells the system that it has shown you the "Do you REALLY want to increase the volume?" dialog and you have agreed.

0

There's an Xposed module to fix that: http://repo.xposed.info/module/com.pyler.nosafevolumewarning

It does the trick for me on the Galaxy Nexus I have plugged into my sound system.

1
  • This is not correct. Even with the mod installed the volume is still reduced. You're just not prompted when you try to raise it. – Jazzepi Mar 9 '15 at 1:17
0

Hey Guys ive had this problem... volume decreasing to mute and youve got no control of it, even when going to settings of media player.. volume goes to mute, its was a simple solution in phone settings. I went to settings/ my device /Sounds & notifictions. There youll see option for sound mode/ Make sure its set to sound and not vibrate or mute. Fixed my Problem with galaxy S4 . Dont know how the setting got changed but it while my phone was connected to my laptop via USB & the internet was on, Sum bug may have changed settings Possiblaly. Fix now

-6

There's no hardware issue. It has a software issue. Problem can be solved in this way

  1. Install an anti-virus software on mobile. I recommend AVG.
  2. Scan device and delete threats apps.
  3. Problem solved
1
  • 1
    And how did you reach to this conclusion? Consider mentioning the source which lead you to this answer. – Firelord Apr 30 '15 at 2:41

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.