0

I managed to root my Verizon s7 sm-g930v but am unable to disable the frp lock. I was locked out of the phone because of the Google verification. It still starts up in the wizard but I installed a side bar app that pops up giving me access to everything on the phone. But I cannot go pass the Google verification in the set up wizard. I tried adding a new user, goes straight to the Google verification page. I tried adding new users then factory resetting...doesn't work. I tried using rootjunkys quick shortcut maker, won't give me the option to change the user login information. Frp is locking this option. I thought maybe there would be some sort of option through adb commands but I'm a newbie at this and not sure how to solve this problem. So, to clarify...I Rooted my S7 but cannot get passed the FRP/Google verification Lock. Any guidance would help a lot. Thanks.

  • How did you root your phone without disabling FRP? Do you have USB debugging enabled? – esQmo_ Feb 2 '17 at 8:19
  • Yes, ther÷ is a button combination to bring you to a screen where you can put it into debugging mode. I discovered it by accident and frustration. Turn off the phone, turn it back on, about 5 seconds after seeing the first start up screen hold power button and volume down. Hold during black screen and the maintenance boot mode options come up. Volume down to number 5:turn on usb debugging option under developer options. Pretty cool find huh – Nancy Feb 4 '17 at 4:36
  • It was a long process. I enabled the usb debugging in the maintenance mode and right when I selected usb debugging with the home button I pressed the power button, home button, and volume down to enter me into the blue screen/downloading. I flashed with Odin file I got from an xda developer thread. However the file did not completely match up with my type of phone...the sm-g930v but close and it worked. I thought I got nothing to lose lol. The thread instructed after flashing starting another program file supplied in the thread to activate adb command. It roots the phone with this process. – Nancy Feb 4 '17 at 4:56
  • To access the settings I couldn't get passed the setup wizard until I connected to a computer after usb debugging with restart. I used the computer program iroot. It says it's rooting but it actually doesn't do it. After it "roots" in the program u can download programs like settings, access file/storage, facebook, etc. – Nancy Feb 4 '17 at 4:57
  • The downside everything is in Chinese. You can tell by the pics what most of the buttons mean...lol while downloading the programs from the program pop ups will appear if you want to download from untrusted sources...select yes. Getting into settings is possible now and your phone luckily is still in English. Lol in settings, activate bluetooth, connect to another device and share apk files and install. :-) I installed root checker and sure enough my phone was rooted. I also installed the superuser apk. But every time the phone starts it's in the setup wizard asking for the Google verification – Nancy Feb 4 '17 at 4:57
1

Here is a list of steps I wrote for the same device, just the Edge so SM-G935V instead of the SM-G930V, although the process will work exactly the same. If you'd prefer to see an example then here's a link to my video that follows the steps https://youtu.be/UU-nEuCbyfk.

  1. With the phone powered on, hold both volume keys, the home button and then the power button all at the same time until the device shuts off. The very moment it turns off let go of all the buttons and you will boot into maintenance boot mode.
  2. Use the volume buttons to scroll down to enable usb debugging.
  3. Download and extract the files from the following link https://drive.google.com/file/d/0B3i3FRXRZ9VtbEJlSThqS3A4cFk/view and put them somewhere on your desktop.
  4. Open the extracted folder and then open a command prompt or terminal from inside the folder.
  5. Connect the phone to a computer with ADB installed and type the following commands, one at a time, followed by enter:

adb push gam6.apk /sdcard/Download

adb push gam7.apk /sdcard/Download

adb push dcow /data/local/tmp

adb shell

cd /data/local/tmp

touch file

echo FFFFFFFF >> file

chmod 777 *

./dcow /sdcard/Download/gam6.apk /system/priv-app/GoogleLoginService/GoogleLoginService.apk

./dcow file /system/priv-app/GoogleLoginService/oat/arm64/GoogleLoginService.odex

content insert --uri content://settings/secure --bind name:s:user_setup_complete --bind value:s:1

  1. Return to the phone and you will find that the last command you have typed has enabled the functionality of the "Edge" feature. Use this to create 2 shortcuts on the sidebar, one for Settings, and the other for Setup Wizard.
  2. Open Settings and connect to WiFi.
  3. Scroll down from the main screen of Settings and choose Storage > Explore > Downloads and install gam6.apk.
  4. Install Rootjunky's FRP-Bypass.apk and then open the app. Choose the 3 dots in the top right and select Web Sign-In.
  5. Sign in with a Google Account that you own.
  6. When finished you may see an error, don't worry this is nothing to worry about. Just swipe your finger in from the "Edge" to display the shortcuts you created earlier and this time choose Setup Wizard.
  7. Now just proceed through Setup Wizard and you will be able to successfully complete it. At this point I recommend going to Settings and then enable OEM Unlock under Developer Settings (this turns off any trace of FRP).
  8. From here also I recommend to factory reset the device via the Backup & Reset method located inside the Settings menu. When your device finishes you will have unlocked it and are free to do as you please.
0

Completing Google verification should give you complete access to your device. Then go to Settings->Developer Options-> Enable OEM unlocking turn on this option. This should disable FRP lock on your device

  • Developer options are not enabled for this user....me. So I can't. – Nancy Feb 4 '17 at 4:38
  • I tried installing an apk to access developer options for it does not show up in settings. It brings me to the developer settings but it is empty and says that I don't have permission still. – Nancy Feb 4 '17 at 4:41
0

You can try bypassing the FRP with ADB pm commands by hiding Setup Wizard package.

Open ADB terminal, connect the phone then type:

adb shell (hit enter) pm hide com.google. android.settings (hit enter)

The setup should be bypassed. Note that the package name should be different. To be sure, type adb shell pm list packages

Or, alternatively, download Deloater. It makes it easier to find and remove/hide packages.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.