0

I've spent much time reading up on my issue with no progress at all. I have a problem with a Huawei Ascend G630.

I have never rooting my phone or flashing a custom rom. The phone does not work, I can’t reset it by pressing volume up, down and power, and only when it’s on charge, it shows the message:

"Recovery image verify failed Please update to the authorized images”.

I removed the battery, then, I tried getting it into the recovery mode to reset It or even flash its stock firmware following this instruction to solve it:

1) I downloaded HUAWEI G630 Firmware from here: http://consumer.huawei.com/kh/mobile-phones/support/downloads/detail/ascend-g630-kh.htm?id=26062

2) I extracted Huawei Smartphone firmware (UPDATE.APP) on my PC and then I have pasted it on micro SD card.

The process doesn’t start and the phone returns to the first message
“Recovery image verify failed”.

I think that bootloader is locked.

I enclosed a picture.enter image description here

Please help me. Thanks.

3
  • Do yourself a favor and edit your question and delete your IMEI number... It is of no relevance to the issue and people steal these all the time.
    – acejavelin
    Feb 3, 2017 at 11:44
  • Ok sorry, I thought it was important. Thank you. Feb 3, 2017 at 12:39
  • IMEI, MEID, ESN, and serial numbers are all specific to a single device... Sharing them is not a good idea, people use them to clone devices. Other information like kernel, baseband, system, or build versions are fine, those are more generic and cover a variety of handsets in common.
    – acejavelin
    Feb 3, 2017 at 16:38

1 Answer 1

1

There is a quite simple workaround to solve your problem.

  • First you should search (on XDA example) and download an original-recovery.bin for your device.
  • After you can flash it in fastboot mode with the following command:
    • fastboot flash recovery original-recovery.bin

After this you have an original bootloader on your device.


Source: XDA-Developers

7
  • I wrote:"fastboot flash recovery original-recovery.bin" Prompt shows: “error: cannot load original-recovery.bin"; I downladed and extracted suggested file on XDA in a folder on my PC. So, I wrote this command:"fastboot reboot recovery.img",because in the folder called ADB that I downloaded, there are this file: 1)adb.exe;2)AdbWinApi.dll;3)AdbWinUsbApi.dll;4)boot.img;5)cwm.img; 6)fastboot.exe;7)recovery.img. Feb 6, 2017 at 9:55
  • There was no such thing as a "suggested file on XDA", I just linked it as SOURCE. The file you've downloaded is for an other device (for Huawei Ascend G6-U10) not for your G630. I wrote in my answer in the very first step to download an original-recovery.bin for your device. Take an other round but in this time use a (device) correct original recovery. But I will edit my answer if it's not crystal clear to everyone. Feb 6, 2017 at 10:01
  • I just tried to use this file, becauseI didn't foundthat for G630. When I wrote this command "fastboot reboot recovery.img", prompt shows "usage: fastboot [ <option> ] <command>" and it suggests to me some commands and options. Feb 6, 2017 at 10:27
  • commands: update <filename> flashall flash <partition> [ <filename> ] erase <partition> getvar <variable> boot <kernel> [ <ramdisk> ] flash:raw boot <kernel> [ <ramdisk> ] devices continue reboot reboot-bootloader options: -w -s <serial number> -p <product> -c <cmdline> -i <vendor id> -b <base_addr> -n <page size> According to you, what should I do now? Feb 6, 2017 at 10:30
  • You can't use whichever device's recovery. You should find a proper recovery for your device. Use the search on XDA, or Google it. Further more your command is meaningless, to boot up your device into fastboot mode use this: adb reboot-bootloader. Feb 6, 2017 at 11:10

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .