0

I have a LG G3 S (LG G3 Beat / D722) and recently I changed my ROM to Lineage OS 14.1. To achieve this, I followed this steps:

  1. I rooted device with kingoroot
  2. I installed twrp recovery
  3. I downloaded lineage and flash it with twrp from an SDCard
  4. All goes ok except for:

    a) Although I can connect through cellular network, I can not connect through wifi. Strange thing is that the phone is able to detect surrounding wifi networks but when connecting it says "connecting" for a while and then just "saved". I can then click as many times as I want but it does not connect (no, the password is not wrong, I tried on several networks). I noticed that in wifi menu MAC Address and IP are not detected (MAC Address is displayed as 00:00:00:00 (bunch of zeros) and IP address returns "unavailable")

    b) When trying to connect to play store with cellular network it says "no response from servers". I think it might be related with MAC Address unavailability...

  5. I thought it could be because I was trying nougat, which is still very fresh. However, I tried android 6.0 (with Resurrection Remix) and happened exactly the same.

Any thoughts, please?

0

It is quite possible the problem to be coming from the kernel, but you are free to try and set a mac address. If you are rooted you can install Xposed framework and try "id changer xposed". If it doesn't help you can make a full nandroid backup so you don't loose any data and try flashing different roms and kernels and see if the same problem still exists.

0


I have same problem but solve it with following instruction:

You can solve this problem with this: go to:

"setting->wifi->advanced->Wi-Fi region code"

Then change it to Europe or anything will work.
Like below image:
enter image description here

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.