0

I have recently installed GNURoot Debian and I really enjoy having Bash on my phone and access to the vast repository for various other GNU/Linux programs.

But when I tried downloading a package from source and running ./configure, I noticed it doesn't work because its executable flag is removed. I tried running chmod +x configure and there was no change (its still not executable!). So finally I ran sh configure, and configure started, but after a few lines there was an error because the program that was built by GCC couldn't be executed:

configure: error: cannot run C compiled programs.
If you meant to cross compile, use `--host'.

I have to say that my phone is not yet rooted. So I wanted to see if there is a solution to this without rooting? or if this is a GNURoot issue or a general issue? or if rooting will make a difference.

  • The program that was built? Configure doesn't compile anything normally... – jiggunjer Feb 8 '17 at 14:27
  • For its tests, configure compiles many small programs. I added the configure error in the post. Compilation was done successfully, but it hasn't been able to execute/run the compiled program. – makhlaghi Feb 8 '17 at 14:41
  • I guess it's installed on the SD card, right? Which is mounted with the noexec flag for security reasons. See e.g. this answer. – Izzy Feb 8 '17 at 15:54
  • Thanks lzzy, I just had a check, it is installed on /storags/emulated/0/. If I am not mistaking, this not the SD card, is it? – makhlaghi Feb 8 '17 at 16:27

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.