4

I have an LG G3 (d855) phone on which I had Cyanogenmod 14 and which I wanted to upgrade to LineageOS.

I booted to recovery, wiped everything and tried using adb sideload to load the image, but it failed at 47% with cannot verify whole file signature and cannot load volume /misc errors.

I verified the md5sum of the image, tried the other images available and also an AOKP image, and the symptoms are always the same.

I don't seem to have access to another way of loading an image on the phone, I was not able to enter download mode (I only get either a black screen or a battery picture), and the recovery mode seems to accept adb connections so I cannot push an image on it (I get a adb: error: connect failed: device unauthorized. This adb server's $ADB_VENDOR_KEYS is not set error). And of course having wiped the system, I cannot do anything from here.

Edit : I've been able to start the phone in download mode by using a different USB cable. However, I cannot find a tool on Linux to upload an image to it. Some sites say that heimdall should support it but it seems they are misleading as heimdall itself only claims to support Samsung devices.

  • Do you have TWRP installed? Can't you just use it's MTP mode to copy the ROM and Gapps to internal storage and flash from there? – acejavelin Feb 12 '17 at 18:22
  • No, I only have the Cyanogenmod recovery and it doesn't have many features, all of which I already tried. – user60039 Feb 12 '17 at 21:06
2

So I was finaly able to solve my problem :

  1. Apparently the failure of adb sideload at exactly 47% is a known bug on TWRP, so I would assume that it's the same bug bitting me on Cyanogen recovery.

  2. Anyway, if the recovery doesn't allow to install a ROM, there is the download mode (volume UP and plug in an USB cable).

  3. If download mode doesn't work, try it with another USB cable (such as the one that came with the phone)

  4. Have a Windows install available either physically or in a VM as LG couldn't bother supporting other OSes.

  5. Follow this tutorial to reinstall the original LG ROM, but at step 7 tick the "Board DL" box as not to get stuck on "Factory Reset Status 2" such as explained in this reddit thread (doesn't seem to be a problem for everyone).

  6. Reroot the phone and reinstall a ROM that isn't full of LG bloatware.

(Note for self : next time buy a device that hasn't been designed to work against it's owner)

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.