0

I've ported a twrp 3.0.2 to my device (kitkat 4.4), all works nice, but when I try press backup, and select store, only shows the internal store...

Device description: Azumi a50c+ with rom Kitkat 4.4. Its a MT6582

NOTE: this works fine in twrp 2.7 but then try change to 3.0.2 the sdcard cant be select in the options

My partition is:

=================
Phone store: 8GB, divide in: 
    Internal store >> 4.2GB
    ext sd card (this is a internal partition of phone store) >> 2.33
    System rom.....

=================


=================

SDCARD: 16 GB

THIS IS THE PROBLEM, In the recovery sdcard 16gb is detected in this partition in mmcblk1p1 but cant see the sdcard in "select store" option of twrp 3.0.2.

Problem

=================

What files of ramdisk should I modify? check the images...

TWRP 3.0.2 To port

TWRP 2.7 old, works fine

Recovery Stock of my Kitkat

What is the best way to fix bug of my TWRP 3.0.2? Thank you very much

  • Which device? I guess you done something wrong or missed in fstab so it doesn't handling it well. That happens when you port. The best way is to find device tree and modify it to fit twrp needs and compile it from source. Question will probably be locked due it more fits developement questions. So feel free to contact me if you need help i'm not expert but maybe I can help. – Једноруки Крстивоје Feb 10 '17 at 20:23
  • @ЈеднорукиКрстивоје Thank you very much dude, I've solved it, the problem was in fstab and one line of init.rc... Greetings! :D – Milor123 Feb 10 '17 at 20:32
  • @ЈеднорукиКрстивоје hey dude, can you help me with this: android.stackexchange.com/questions/169120/… Thank you – Milor123 Feb 14 '17 at 19:32
0

I've solved it

Note: this process requiere extract files of recovery.img, you can use "CarlivImageKitchen"


add this line and flags to the /etc/recovery.fstab files, and chage /sdcard to /external_sd example:

The mmcblk1p1 is the block of my sdcard:

 # Extructure is:
 # Mountpoint #type  #partition block     # block             #flags

/external_sd  vfat  /dev/block/mmcblk1p1  /dev/block/mmcblk1  flags=display="Micro SDcard";storage;wipeingui;removable

Problem Solved!

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.