1

I installed Android Studio with Android SDK from the offical web-site, created a new sample project, didn't change or delete even a line, but the project doesn't work anyway.

D:\AndSDK\tools\emulator.exe -netdelay none -netspeed full -avd Nexus_5X_API_22
Hax is enabled
init: Could not find wglGetExtensionsStringARB!
getGLES2ExtensionString: Could not find GLES 2.x config!
Hax ram_size 0x60000000
Failed to obtain GLES 2.x extensions string!
HAX is working and emulator runs in fast virt mode.
Could not initialize emulated framebuffer
audio: Failed to create voice `goldfish_audio_in'
qemu-system-i386.exe: warning: opening audio input failed
emulator: Listening for console connections on port: 5554
emulator: Serial number of this emulator (for ADB): emulator-5554
emulator: ERROR: Could not initialize OpenglES emulation, use '-gpu off' to disable it.

02/11 16:19:14: Launching app
Error while waiting for device: The emulator process for AVD Nexus_5X_API_22 was killed.

What can be wrong and how to fix it?

1

emulator: ERROR: Could not initialize OpenglES emulation, use '-gpu off' to disable it.

The emulator wasn't able to use OpenGL ES emulation on your PC. As the message says, you can disable it using the command-line, or by turning off the "Use Host GPU" option in the emulator's settings dialog, but then the emulator will be very slow. It would be better to run your app on a real phone.

| improve this answer | |
0
  1. Go to: Tools > Android > AVD Manager
  2. Press the "edit" (pencil) icon next to your AVD
  3. Change "Graphics" to "Software".
| improve this answer | |
0

The same happened to me, in other places I read that is a problem with the library shipped with the SDK.

The following line worked for me

$ android-sdk/tools/emulator -avd Nexus_5_API_27 -use-system-libs

Now you can see the device from Android Studio and connect to it. Probably exists an option inside the AVD configuration to fix this.

| improve this answer | |
0

This is what worked for me: Go to Tools> AVD Manager > Click on downward arrow beside your emulator > Wipe data It will confirm if you want to wipe data, say yes in that case.

| improve this answer | |
-2

The-emulator-process-for-avd-nexus-5x-api-22-was-killed???? simple change "Nexus5XApi22" to "Nexus" problem solved.

| improve this answer | |
  • 2
    I'm curious why changing the AVD name will fix the issue about OpenGL ES emulation? – Andrew T. Mar 8 '19 at 10:52
  • I didn't know proper reasons but its working fine – monika lagwal Mar 10 '19 at 15:32
-2

Since the log also mentioned

audio: Failed to create voice 'goldfish_audio_in'

Check your Windows 10's Privacy settings > Microphone. If it is disabled, enable it.

| improve this answer | |
  • Are you saying enabling microphone prevents Emulator process from being killed? How did you reach this conclusion? – Firelord May 3 '19 at 5:34
  • i was referring to this. audio: Failed to create voice goldfish_audio_in' I had the same error with this,. – jepm May 5 '19 at 23:19

Not the answer you're looking for? Browse other questions tagged or ask your own question.