1

I tried parted like

unit MB
rm 34
rm 35
rm 36
mkpart 34 823 2400
mkpart 35 2401 2441
mkpart 36 2441 7818
name 34 system
name 35 kpan
name 36 userdata

and then

mke2fs -t ext4 /dev/block/mmcblk0p34
mke2fs -t /dev/block/mmcblk0p35
mke2fs -t /dev/block/mmcblk0p36

And after reboot nothing applyed. I used this guide this guide

What i'm doing wrong? I need to install Mokee 7.1 but there is no space for gapps. This is a problem. Help me, please, i spent about 8 hours to trying solve it and nothing got( It's sad(

Update: My question is "After i have had resized '/system' partition and after reboot - '/system' partition has the same size. What i'm doing wrong in my flow"

Update "This guide" link fixed (typo)

Update

So finally what have i done:

I read guide described above completely. My device is Motorola Moto G xt1033 (codename 'falcon')

I wanted to install Mokee (android OS) and after installing Mokee there are no left free space for opengapps even for the most small pack (pico).

So i decided to increase 'system' partition. I did everything that was in guide mentioned above and i tried 2 or 3 times and each time after rebooting device 'system' partition remains the same size as before resizing.

The feature of this problem is that i did everything described above with my device XiaoMi RedMi 1s (C/W) (codename 'armani') and 'system' partition (in case of Xiaomi) has been increased (i used guide mentioned above).

So my question is - Why partition remains the same size as before resizing? How to prevent it? What did i miss? What i'm doing wrong? And finally - how to increase 'system' partition for my Motorola Moto G xt1033 (codename 'falcon')?

  • @MarkYisri , did you understand my question? My question is My question is "After i have had resized '/system' partition and after reboot - '/system' partition has the same size. What i'm doing wrong in my flow described in here?" – Link Feb 12 '17 at 9:30
  • I think you misunderstood. You said that "I used this guide", but the link points to your own question. – user186920 Feb 13 '17 at 10:34
  • @MarkYisri , sorry, my bad, i have fixed the link, please, take a look on this link – Link Feb 13 '17 at 18:44
-1

It is not possible.

Adopted storage works for marshmallow version and later. You may not use it on jellybean or even if you updated to lollipop.

I might​ have been wrong in understanding your situation, so please let us know of root status and latest rom or android version you have.

There is also more complexity when creating more than two partitions. Try what has been discussed in https://android.stackexchange.com/a/145458/90095

  • My phone is already rooted. Is has TWRP 3.0 or upper (i don't remember). My currently OS is Mokee (android 6.0) with pico gapps package. I want to install Mokee (android 7.0) with any package i could install. But there is no free space for gapps with Mokee (android 7.0). Why are you talking that "It is not possible." when i already increas 'system' partition on my Xiaomi RedMi 1S (C/W)? I took a look on thread described by you above and there is one more thing: my device (Motorola Moto G xt1033 (codename 'falcon')) has no slots for SD card – Link Feb 13 '17 at 20:43
  • Don't worry, now I think I understand your situation better. Please tell if you unmounted your storage fist and also if you did it in recovery mode or not (Since your guide mentions being in recovery mode as optional however still suggesting that) . Please have a look at this thread for cases targeting internal memory and follow the sequence of entering recovery mode and the unmounting, specified in steps 8 to 11.:forum.xda-developers.com/showthread.php?t=2720675 also you forgot filesystem type after -t, I think it is missed only in this post not on the real scenario you executed. – F.I.V Feb 14 '17 at 7:19

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.